[CentOS] anaconda not installing to sda?

Wed Sep 27 14:47:11 UTC 2017
Christopher Wood <christopher_wood at pobox.com>

I'm having what appears at first glance to be a kickstart+anaconda issue on CentOS 7.4.

As near as I can tell in the program.log in the anaconda environment, the partitioning instructions downloaded with the kickstart from cobbler appear to simply not be applied. Then /mnt/sysimage is not mounted, the logs are not copied to /mnt/sysimage/root and the installation stalls due to the anamon checking. (Also anaconda is trying to e2fsck /dev/loop devices which is puzzling.)

If anybody has hints about what I would double-check or if you've resolved a similar issue I would be quite interested.

More details:

I see the same behaviour after cutting most items out of the cobbler kickstart template, however I confirm that /run/install/ks.cfg in the anaconda environment has the following:

ignoredisk --only-use=sda

bootloader --location=mbr
clearpart --all
part / --label="/" --fstype=ext4 --grow --asprimary

program.log from the anaconda environment is here:


The system does boot and install just fine from the CentOS 7.4 iso without being kickstarted.

This is on vmware (esxi 6.0), I've tried with the paravirtual and lsi logic scsi controllers with the same result.

I've tried different previously (CentOS 7.3) working cobbler profiles that do not work with 7.4 now.

If I change the drive name (sda) to a ludicrous value anaconda simply errors, so at some level it's understanding about sda.