[CentOS] Help with yum

Fri Apr 13 00:48:43 UTC 2018
Paul R. Ganci <ganci at nurdog.com>

On 04/12/2018 08:51 AM, Kay Diederichs wrote:
>> I tried running:
>>> yum groups mark install "X Window system"
>> and get the same message. I tried different permutations removing the
>> "s" on groups. Nothing seems to bring back the yum "X Window system"
>> group. Can anyone help me resolve this issue and tell me what I did wrong?

First, thanks for everyone who tried to help me with this problem. At 
this point I will apologize to the list for what I think is just user 
error. Indeed I have convinced myself that there is no group package "X 
Window system" albeit one may have existed many years ago. For those who 
are interested in the full story continue reading other please accept my 
apology and many thanks for the list help.

Second, here is the full story. I wanted to install Mate after doing a 
minimal install. All the documentation I found on the web indicated that 
after enabling the epel repository I should do this sequence of yum 
commands(or something equivalent):

 > sudo yum groupinstall "X Window system" -y
 > sudo yum groups install "MATE Desktop" -y

Unfortunately I did things in opposite order and when I tried to do

 > startx

X windows would not startup. I swear that the after doing the "yum 
groupinstall "X Window system" that packages were downloaded and 
installed. So I chalked up the X start failure to doing things in the 
incorrect order. So this morning I thought I would start with a clean 
slate and did:

 > yum groupremove "X Window system" "MATE Desktop"
 > yum groupinstall "X Window system"

That is when I received the error message I did in my first post. So 
just now I went back to another CentoOS 7 system running Mate and 
re-produced the yum commands. It turns out the history contained 
everything I needed. In my case I just needed to install the elrepo to 
get the Nvidia drivers for my video card and first installed those:

 > yum install kmod-nvida nvidia-x11-drv

Then it was just a matter of:

 > yum groupinstall "MATE Desktop"
 > systemctl set-default graphical.target
 > reboot

Voila... I have a desktop running MATE!

I think the web instructions I found are outdated (although one web page 
was dated 2/18/2018. There doesn't exist a "X Window system" yum group. 
Generally I tell people when stuff like this happens that digital 
computers can't lie... next time I will take my own advice.

Again thanks to everyone who helped... Your time was appreciated.
Paul (ganci at nurdog.com)
Cell: (303)257-5208