[CentOS] Screensavers on Centos-7

Fred Smith fredex at fcshome.stoneham.ma.us
Wed Aug 1 23:41:30 UTC 2018


Hi all!

I keep having problems with screensaver(s) on Centos-7.

I have in the past liked Xscreensaver, so I've installed it and tried
to suppress whatever other screensaver is on the system. Xscreensaver
works fine for a day or 20 then quits working. After a lengthy battle
I gave up and removed it.

I'm now trying mate-screensaver, which does the same thing!

when I say "quits working" I mean just that. one night it goes to a
black screen (as configured) then a minute or two later the power manager
shuts off the screen. The next night it does neither, and forever after.

Sometimes after a reboot it'll work again for a while then it starts
misbehaving again.

First question: Anybody have any similar issues? Anybody have any ideas
on what's going on here and what I can do about it?

So, not being in a position to reboot, last night I killed
mate-screensaver and mate-powermanager, with the hopes the daemons
would restart themselves. No such luck. so I tried to figure out what
programs I could run to get them started again. So far I'm too stupid
to be able to figure that out, as well.

Second question: Anybody able to clue me in on how the screensavers
and power managers are managed/started? there isn't a systemctl
module for it, as far as I can see. if I run mate-screensaver from
the commandline (as me, not root) I get no prompt back, so I assume
it's running silently, but it also doesn't blank the screen at the
specified time.

So, thanks in advance for any assistance!

-- 
---- Fred Smith -- fredex at fcshome.stoneham.ma.us -----------------------------
    "Not everyone who says to me, 'Lord, Lord,' will enter the kingdom of
    heaven, but only he who does the will of my Father who is in heaven."
------------------------------ Matthew 7:21 (niv) -----------------------------



More information about the CentOS mailing list