[CentOS] CR repo update disaster for my desktop.

Mon Dec 3 05:25:26 UTC 2018
Rob Kampen <rkampen at kampensonline.com>

I have a centos 7.5 desktop workstation with dual nvidia graphic cards running three monitors. I use the i915 motherboard graphics adapter for the third monitor with bumblebee to work the magic to enable the three contiguous work spaces.
I use the kmod nvidia drivers for the two graphics cards. This has worked without a hitch for 5 months until this weekend. 
I enabled the CR repo and did the yum update. Some 800+ rpms were offered and all seemed to resolve depenancies OK, so yes it was started. The updates completed and all looked good, until the reboot. 
Initially the new kernel would boot just fine but the gdm/gnome desktop hung. No login offered. 
Reboot and select previous kernel, great, offered login, but the desktop barely settles before gnome crashes, and gdm restarts and I get to login afresh. 
Eventually I have, removed bumblebee, disabled the on board graphics adapter, reinstalled gnome multiple times, removed nvidia drivers, blown away my .gnome and related folders, tried as a new user, (no customizations of the desktop) all to no avail. 
Current situation is under my user account cannot get stable desktop for more than 10 seconds before it sends segfault error 4 in libc-2.17.so
What do I do now? 
Seems that these big updates need to be applied in sub batches with reboots in between so that one can back out. 
Any ideas appreciated. 

⁣Sent from BlueMail ​