[CentOS] Accidentally nuked my system - any suggestions ?

Tue Dec 4 22:01:51 UTC 2018
Nicolas Kovacs <info at microlinux.fr>


My workstation is running CentOS 7 on two disks (sda and sdb) in a
software RAID 1 setup.

It looks like I accidentally nuked it. I wanted to write an installation
ISO file to a USB disk, and instead of typing dd if=install.iso
of=/dev/sdc I typed /dev/sdb. As soon as I hit <Enter>, the screen froze.

I tried a hard reset, but of course, the boot process would stop short
very early in the process.

Now, I have backups of the important stuff of course, so no real
catastrophe. But it would be nice if I could get back the data from my
disk directly.

I booted a rescue disk (Slax 9.6.4) and I can see my disks as well as
raid arrays /dev/md125, /dev/md126 and /dev/md127. Oh, my partitioning
scheme is manual and quite simple. Everything is RAID 1, I have a /boot
array on /dev/sda1 + /dev/sdb1, swap on /dev/sda2 + /dev/sdb2 and / on
/dev/sda3 + /dev/sdb3.

I tried to mount /dev/sda3 directly from the rescue disk:

  # mount /dev/sda3 /mnt

But I only get this:

  mount: unknown filesystem type 'linux_raid_member'

I'd be very grateful for suggestions.



Microlinux - Solutions informatiques durables
7, place de l'église - 30730 Montpezat
Site : https://www.microlinux.fr
Blog : https://blog.microlinux.fr
Mail : info at microlinux.fr
Tél. : 04 66 63 10 32