[CentOS] IPv6: ADDRCONF(NETDEV_UP): link is not ready after upgrading to 7.6

Wed Dec 26 07:54:22 UTC 2018
Luigi Rosa <lists at luigirosa.com>

Hi, after upgrading to 7.6, kernel 3.10.0-957.1.3.el7.x86_64, at boot instead of 
the GUI login screen I got two lines like this:

IPv6: ADDRCONF(NETDEV_UP): em1: link is not ready
IPv6: ADDRCONF(NETDEV_UP): em1: link is not ready

The server is accessible via ssh on IPv4

Server:  DELL PowerEdge T 110 II

NIC: Broadcom, driver tg3, lspci -v:
04:00.0 Ethernet controller: Broadcom Inc. and subsidiaries NetXtreme BCM5722 
Gigabit Ethernet PCI Express
         Subsystem: Dell Device 04de
         Flags: bus master, fast devsel, latency 0, IRQ 33
         Memory at c4a00000 (64-bit, non-prefetchable) [size=64K]
         Expansion ROM at <ignored> [disabled]
         Capabilities: [48] Power Management version 3
         Capabilities: [50] Vital Product Data
         Capabilities: [58] Vendor Specific Information: Len=78 <?>
         Capabilities: [e8] MSI: Enable+ Count=1/1 Maskable- 64bit+
         Capabilities: [d0] Express Endpoint, MSI 00
         Capabilities: [100] Advanced Error Reporting
         Capabilities: [13c] Virtual Channel
         Capabilities: [160] Device Serial Number f8-db-88-ff-fe-fe-b4-57
         Capabilities: [16c] Power Budgeting <?>
         Kernel driver in use: tg3
         Kernel modules: tg3

dmesg says:
[    8.075141] tg3 0000:04:00.0 em1: Link is up at 1000 Mbps, full duplex
[    8.075153] tg3 0000:04:00.0 em1: Flow control is off for TX and off for RX
[    8.075174] IPv6: ADDRCONF(NETDEV_CHANGE): em1: link becomes ready

IPv6 is configured as IGNORE in NetworkManager.

I tried the following with the same result:

net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.all.disable_ipv6 = 1

and reboot, no effect

Setting an automatic IPv6 address: no effect.




+--[Luigi Rosa]--