[CentOS] lshw in centos 7

Fri Jan 12 01:33:41 UTC 2018
Stephen John Smoogen <smooge at gmail.com>

On 11 January 2018 at 20:23, david <david at daku.org> wrote:
> Folks
> I've been running lshw for years in both Centos 6 and Centos 7, yet just
> recently it started hanging.  Neither a Control^C nor a "kill" of the
> process cured the hang; only a reboot.

Is this just one system or a range of boxes? I just ran it on 2
different ones running CentOS 7 and it worked fine there. If it is
just one particular hardware then look through the lshw man page and
try the versions of something like

lshw -disable usb

to see if it still happens. [It might require other tests also.]

> When I run it by hand from the command line, it displays stuff on the next
> line overwriting it with things like PCI, USB.  And USB is the last thing I
> see.  A Control-C does not unlock it.
> I am running lshw-B.02.18-7.el7.x86_64.  The CPU is an Intel I7-3770K,
> running CentOS 7.4.1708
> Is there any idea? Is there some alternate program that could list the
> hardware?
> Thanks
> David
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> https://lists.centos.org/mailman/listinfo/centos

Stephen J Smoogen.