[CentOS] Centos 7 add-on serial cards

Sun Jan 28 17:10:29 UTC 2018
Pete Geenhuizen <pete at geenhuizen.net>

I'm upgrading from CentOS6 to CentOS 7.

I run 2 weather stations on C6 and have one of them attached to ttyS0 
which is on the motherboard, and the other to ttyS2 which in on an 
add-on PCI serial card.

I'm migrating the weather stations another host running C7 which has a 
similar hardware configuration.  When I connect the weather station to 
ttyS0 everything works fine, but when I try to use ttyS1 or ttyS2 
nothing happens.

The OS identifies all 3 ports, and I've already tried several different 
serial cards several of the slots on the motherboard all have yielded 
the same result.  I've even gone so far as to try to get this to work on 
another computer running C7 with the same result, success on ttyS0, but 
nothing nothing when I try ttyS1 or ttyS2.

I'm thinking that this might be a driver issue, but having used several 
different cards I'm just not sure.

Any assistance would be greatly appreciated.


Unencumbered by the thought process.
  -- Click and Clack the Tappet brothers

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.