[CentOS] Firefix 60.10-5 ESR Install Problems For CentOS 6

Paul E. Virgo Paul.E.Virgo at nasa.gov
Fri Jul 13 20:03:46 UTC 2018


Johnny/et al,

Looks like we've run into some issues with incompatible libs for the new 
Firefox 60 ESR install:

> root at gs6102dsclxpub1:~# yum -y update firefox
> Loaded plugins: list-data, security
> Setting up Update Process
> group-centos-adobe | 2.9 kB     00:00
> group-centos-bigfix | 2.9 kB     00:00
> group-centos-epel | 3.0 kB     00:00
> group-centos-extras | 2.9 kB     00:00
> group-centos-gbase | 2.9 kB     00:00
> group-centos-os | 3.6 kB     00:00
> group-centos-salt | 2.9 kB     00:00
> group-centos-updates | 3.4 kB     00:00
> Resolving Dependencies
> --> Running transaction check
> ---> Package firefox.x86_64 0:52.8.0-1.el6.centos will be updated
> ---> Package firefox.x86_64 0:60.1.0-5.el6.centos will be an update
> --> Processing Dependency: nss >= 3.36.0 for package: 
> firefox-60.1.0-5.el6.centos.x86_64
> --> Processing Dependency: nspr >= 4.19.0 for package: 
> firefox-60.1.0-5.el6.centos.x86_64
> --> Processing Dependency: libnss3.so(NSS_3.30)(64bit) for package: 
> firefox-60.1.0-5.el6.centos.x86_64
> --> Finished Dependency Resolution
> Error: Package: firefox-60.1.0-5.el6.centos.x86_64 (group-centos-updates)
>            Requires: nspr >= 4.19.0
>            Installed: nspr-4.13.1-1.el6.x86_64 (@group-centos-os)
>                nspr = 4.13.1-1.el6
>            Available: nspr-4.10.6-1.el6_5.i686 (group-centos-os)
>                nspr = 4.10.6-1.el6_5
>            Available: nspr-4.10.8-1.el6_6.i686 (group-centos-os)
>                nspr = 4.10.8-1.el6_6
>            Available: nspr-4.10.8-2.el6_7.i686 (group-centos-updates)
>                nspr = 4.10.8-2.el6_7
>            Available: nspr-4.11.0-0.1.el6_7.i686 (group-centos-updates)
>                nspr = 4.11.0-0.1.el6_7
>            Available: nspr-4.11.0-1.el6.i686 (group-centos-os)
>                nspr = 4.11.0-1.el6
> Error: Package: firefox-60.1.0-5.el6.centos.x86_64 (group-centos-updates)
>            Requires: libnss3.so(NSS_3.30)(64bit)
> Error: Package: firefox-60.1.0-5.el6.centos.x86_64 (group-centos-updates)
>            Requires: nss >= 3.36.0
>            Installed: nss-3.28.4-4.el6_9.x86_64 (@group-centos-updates)
>                nss = 3.28.4-4.el6_9
>            Available: nss-3.16.1-14.el6.i686 (group-centos-os)
>                nss = 3.16.1-14.el6
>            Available: nss-3.18.0-5.3.el6_6.i686 (group-centos-os)
>                nss = 3.18.0-5.3.el6_6
>            Available: nss-3.21.0-8.el6.i686 (group-centos-os)
>                nss = 3.21.0-8.el6
>            Available: nss-3.27.1-13.el6.i686 (group-centos-os)
>                nss = 3.27.1-13.el6
>            Available: nss-3.28.3-3.el6_9.i686 (group-centos-updates)
>                nss = 3.28.3-3.el6_9
>            Available: nss-3.28.4-1.el6_9.i686 (group-centos-updates)
>                nss = 3.28.4-1.el6_9
>            Available: nss-3.28.4-3.el6_9.i686 (group-centos-updates)
>                nss = 3.28.4-3.el6_9
>  You could try using --skip-broken to work around the problem
>  You could try running: rpm -Va --nofiles --nodigest
> root at gs6102dsclxpub1:~#
This is occurring on all of our CentOS 6.9 workstations. Any advice? 
Thanks.

PEV

-- 
Paul E Virgo
Sr. System Administrator
Code 610.2
SESDA III - DAAC/DISC
Goddard Space Flight Ctr/NASA
Greenbelt, MD
Greenbelt, MD 20771
(301) 614-5751




More information about the CentOS mailing list