[CentOS] kvm & permission denied

Sun Jul 15 19:45:48 UTC 2018
Gregory P. Ennis <PoMec at PoMec.Net>

On 07/15/2018 07:16 AM, Gregory P. Ennis wrote:
> The installation seemed to go well, but when I tried to add Fedora 27
> with virt-manager I have continued to get file permission errors.  I
> have tried turning selinux off,

Don't turn SELinux off.

> and making sure the directory
> permissions are 777 and the file permissions are 666, but have not
> been
> able to succeed.

Don't completely disable your security systems.

> The Error Message from virt-manager is :
> Unable to complete install: 'internal error: process exited while
> connecting to monitor: 2018-07-15T13:55:37.836269Z qemu-kvm: -drive
> file=/home/greg/Downloads/Fedora/f27/Fedora-Workstation-Live-x86_64-
> 27-
> 1.6.iso,format=raw,if=none,id=drive-virtio-disk0: Could not open
> '/home/greg/Downloads/Fedora/f27/Fedora-Workstation-Live-x86_64-27-
> 1.6.iso': Permission denied'

/home/greg will be protected from other users by default.  You would 
need to change permissions on that directory from 0700 to 0701 to use
ISO there.  The "right" fix, though, would be to copy the ISO file to 



I appreciate your admonition about selinux and the protectioin levels
of the directories.  As soon as I discovered that these aspects were
not the issues, I changed them back to the original values. 

The location of the iso image in /var/lib/libvirt/images/ directory
fixed the problem and allowed me to proceed with my laboratory
development. Thank you very much.  After knowing the importance of the
location of the iso image files,  I re-read the tutorials and I could
not identify this piece of information, hopefully this thread will help
others that are newbies with kvm.

Thanks again!!!!


Gregory P. Ennis, M.D., M.R.O.
Medical Director
EcCare Health Centers