[CentOS] Issues booting centos7 [dracut is failing to enable centos/root, centos/swap LVs]

Mon Jul 30 16:32:53 UTC 2018
Yannis Milios <yannis.milios at gmail.com>

> But, what happens if you let the kernel post install scripts do the work
> or setting up the initrd things?

Initially, I just rebooted from LiveCD and left Grub,kernel and dracut do
their job with the defaults, but unfortunately, boot process stops at
initrd (dracut) stage with the following error:

[  197.768159] localhost.localdomain dracut-initqueue[252]: Warning: Could
> not boot.
> [  197.821409] localhost.localdomain systemd[1]: Received SIGRTMIN+20 from
> PID 254 (plymouthd).
> [  197.822328] localhost.localdomain dracut-initqueue[252]: Warning:
> /dev/centos/root does not exist
> [  197.823044] localhost.localdomain dracut-initqueue[252]: Warning:
> /dev/centos/swap does not exist
> [  197.846807] localhost.localdomain systemd[1]: Starting Dracut Emergency
> Shell...
> [  197.870983] localhost.localdomain systemd[1]: Received SIGRTMIN+21 from
> PID 254 (plymouthd).

Then, I'm dropped to dracut shell, where I boot the system by using the lvm
commands as described to my first post.
Once in O/S, I re-create initrd by using 'dracut -f -v -a lvm' command and
reboot again the system.
But still I get the same error during boot ...

If you reinstall the latest kernel, does
> it change anything?

 This is actually the latest kernel (3.10.0-862.9.1.el7.x86_64) but I tried
to boot with the second (older) kernel
(vmlinuz-3.10.0-327.36.3.el7.x86_64), where I got exactly the same error
during boot.

Clearly, this is not a kernel issue, perhaps not even a dracut (initrd)
issue, since everything was working fine, before resizing the PV/LV. I
suspect that something went wrong during that step, but what? As I can
successfully boot the system manually via dracut, normally everything
should be ok? no?

What can prevent dracut from activating the 2 LVs (centos/root and
centos/swap) during initial boot phase ?