[CentOS] Samba issues with Win 10

Fri Jun 29 23:13:21 UTC 2018
Fred Smith <fredex at fcshome.stoneham.ma.us>

On Thu, Jun 28, 2018 at 06:55:21PM -0700, Gordon Messmer wrote:
> On 06/28/2018 07:30 AM, mark wrote:
> >    Just ran into a problem: someone with a new laptop, running Win 10,
> >version 1709, tried to map their home directory (served from a CentOS
> >6.9 box, and it fails, with Windows complaining that it no longer
> >supports SMBv1, and if you go to their site, you can install support
> >for that manually....
> https://wiki.samba.org/index.php/Samba_3.6_Features_added/changed#SMB2_support

FWIW, with Centos-7 and windows 10, I was finally able to map a Linux
directory to a windows drive, successfully. Problem was selinux, which
I proved by temporarily disabling it (setenforce 0). Doing
"setsebool -P samba_enable_home_dirs 1" then reenabling selinux
(setenforce 1) seems to have fixed it. at least for now.

BTW, I also have max and min smb versions set to 3_11 in my smb.conf
and it all still seems to work.

With 6.9 some of the values/settings may need to be different, but
one thing to check when remote stuff doesn't work, and you've
checked everything else, is to try with setenforce 0. If it suddenly
miraculously works, then its a selinux issue.

---- Fred Smith -- fredex at fcshome.stoneham.ma.us -----------------------------
  "And he will be called Wonderful Counselor, Mighty God, Everlasting Father,
  Prince of Peace. Of the increase of his government there will be no end. He 
 will reign on David's throne and over his kingdom, establishing and upholding
      it with justice and righteousness from that time on and forever."
------------------------------- Isaiah 9:7 (niv) ------------------------------