[CentOS] Yum dependency failure installing latest LibreOffice

Tue May 29 01:08:26 UTC 2018
Fred Smith <fredex at fcshome.stoneham.ma.us>

I've been bashing my head on the wall for 2 or 3 hours for something that
should be (and has been, in the past) simple.

Trying to install the latest LibreOffice downloaded from Libreoffice.org.
I had and downloaded, and kept getting dependency errors:

--> Running transaction check
---> Package libobasis6.0-base.x86_64 0: will be installed
---> Package libobasis6.0-calc.x86_64 0: will be installed
---> Package libobasis6.0-core.x86_64 0: will be installed
--> Processing Dependency: libreoffice6.0-ure <= for package: libobasis6.0-core-
Loading mirror speeds from cached hostfile
 * base: mirror.net.cen.ct.gov
 * elrepo: mirrors.coreix.net
 * epel: fedora-epel.mirrors.tds.net
 * epel-debuginfo: fedora-epel.mirrors.tds.net
 * extras: linux.cc.lehigh.edu
 * nux-dextop: mirror.li.nux.ro
 * updates: mirror.atlanticmetro.net
--> Processing Dependency: libreoffice6.0-ure >= for package: libobasis6.0-core-

while trying to work around that I "yum remove"d all existing libreoffice
rpms, but that didn't fix it.

the file libreoffice6.0-ure- exists in the same
directory as all the other files I'm trying to install, and as far as
its filename goes, it is the version that yum is demanding.

I tried installing the version I had previously been using, and I get
the equivalent error when trying that too. Back when I installed it, I
got no such errors.

Note that I am now on the 7.5 version, 7.5 (1804), and when I previously
installed 6.0 I was still on the previous release, so I wonder if yum has
become broken during the 7.5 run-up.

A lot of time had transpired here and I was getting a little warm under
the collar, so I tried:

rpm -ivh *.rpm

which worked just fine. voila! I did this with the older version, but I
wanted the newer one, so I did "yum remove libreoffice\* libobasis\*"
and it complained about the RPM database being modified, but it did the

then I tried installing again, with yum, which still gives the
same error.

Once again, rpm is my friend.

Anybody got any ideas what's wrong with my system? (or is yum broken??)

thanks in advance!

---- Fred Smith -- fredex at fcshome.stoneham.ma.us ----------------------------
                    Do you not know? Have you not heard? 
    The LORD is the everlasting God, the Creator of the ends of the earth. 
  He will not grow tired or weary, and his understanding no one can fathom.
----------------------------- Isaiah 40:28 (niv) -----------------------------