[CentOS] C7 and NVIDIA driver

Thu Sep 20 14:04:56 UTC 2018
Alessandro Baggi <alessandro.baggi at gmail.com>

Hi all,
I'm running C7 on i7 8700k/asus z370-a with an GTX1050.
I noticed that there are several problems installing Nvidia proprietary 
driver. After one week of troubleshooting I got my solution. Hope that 
can help other user.

I found this https://access.redhat.com/solutions/3438891 but I've not 
access to this content. In this content seems that the workaround is 
using lightdm and mask gdm.

The case:

I tried using proprietary driver from nvidia site and from elrepo.
In all the case I got system that hungs during boot. In a first time I 
got message about a device probing (and some kernel trace about i915) 
and running systemd-analyze blame seems that udev-settle hungs for 
several minutes. Some suggested to disable udev-settle if you does not 
have LVM but this is not my case.
After this error I got error with GDM (infinite hungs) so I tried 
lightdm that works blinking.

So I switched to multi-user level, I got always udev-settle hung but 
running startx system works but with some strange behaviuour.

Now I tried another solution. I installed kernel-lt, kernel-lt-devel and 
reinstalled NVIDIA driver. All works very well also reenabling graphical 

best regards