[CentOS] nobody:nobody

Wed Apr 3 21:17:17 UTC 2019
Mark LaPierre <marklapier at gmail.com>

On 4/3/19 6:43 AM, mark wrote:
> On 04/02/19 20:21, Mark LaPierre wrote:
>> Hey Y'all,
>> For the last week or more I've been trying to get NFS and OpenLDAP to 
>> play nice with each other.  I've pretty much worn the Google machine 
>> out trying to find a solution.  I've found several that said "Solved" 
>> but none of those solutions solved my nobody:nobody problem.
>> In the past I've used NFS in conjunction with NIS to share home 
>> directories from my NFS server but I read that NIS is deprecated in 
>> favor of LDAP so, being a sucker for new ideas, I decided I would use 
>> LDAP too like the big boys do.  I think I'm regretting this decision. 
>> Now the question:
>> Is there something I need to configure on the client side of the 
>> relationship that all the Google wisdom has failed to mention?  All the 
> I'd assume: have you edited /etc/idmapd.conf, and at least put in your 
> domain? Then started the imapd daemon?
> Btw, when you go to C 7, there's no imapd daemon, but you still need to 
> edit that file.
>      mark
>> guides/tutorial/etc... talk extensively about configuring the server, 
>> many giving conflicting information, but have nothing to say about the 
>> client. I've even found a couple that talk about configuring CentOS 6 
>> but contain commands found only in CentOS 7.  Makes one go hmmm?
>> Here's the basic details:
>> Server:
>> CentOS 6
>> openldap-2.4.40-16.el6.i686
>> openldap-clients-2.4.40-16.el6.x86_64
>> perl-LDAP-0.40-3.el6.noarch
>> sssd-ldap-1.13.3-60.el6_10.2.x86_64
>> openldap-2.4.40-16.el6.x86_64
>> openldap-servers-2.4.40-16.el6.x86_64
>> python-ldap-2.3.10-1.el6.x86_64
>> apr-util-ldap-1.3.9-3.el6_0.1.x86_64
>> smbldap-tools-0.9.6-4.el6.noarch
>> nfs-utils-lib-1.1.5-13.el6.x86_64
>> nfs4-acl-tools-0.3.3-8.el6.x86_64
>> nfs-utils-1.2.3-78.el6_10.1.x86_64
>> Client:
>> CentOS 7 KVM VM running on the server
>> sssd-ldap-1.16.2-13.el7_6.5.x86_64
>> python-ldap-2.4.15-2.el7.x86_64
>> openldap-2.4.44-21.el7_6.x86_64
>> nfs4-acl-tools-0.3.3-19.el7.x86_64
>> nfs-utils-1.3.0-0.61.el7.x86_64
>> libnfsidmap-0.25-19.el7.x86_64
>> Both machines are fully updated.
>> Would you like to see any of the myriad of configuration files for 
>> these applications?  Just ask and you shall receive.  Please be sure 
>> to tell me if you want the file from the server or the client hey.

Content of idmapd.conf:
#Verbosity = 0
# The following should be set to the local NFSv4 domain name
# The default is the host's DNS domain name.
#Domain = local.domain.edu
Domain = peach.patch.mylan

#Verbosity = 0
# The following should be set to the local NFSv4 domain name
# The default is the host's DNS domain name.
#Domain = local.domain.edu
Domain = poppy.patch.mylan

Now one more question.  The imap daemon is a mail server.  How is it 
that I need a mail server running to make LDAP and NFS work?  Doesn't 
seem to make sense to me.

    ^ ^  Mark LaPierre
Registered Linux user No #267004