[CentOS] update failure

Mon Apr 22 16:12:09 UTC 2019
Emmett Culley <lst_manage at webengineer.com>

On 4/21/19 10:15 AM, Ulf Volmer wrote:
> On 21.04.19 16:14, Emmett Culley via CentOS wrote:
>> When I attempted to update a remote server via SSH last night the UPS on
>> my local workstations failed, causing the SSH session to get dropped in
>> the middle of the upgrade process.  This morning I am not able to
>> complete the update.  When it failed when I tried to run it again thins
>> morning I did the suggested things like "dnf clean all" and "rpm
>> -rebuilddb", and I still get this after it downloads the packages again:
>> Running transaction test
>> The downloaded packages were saved in cache until the next successful
>> transaction.
>> You can remove cached packages by executing 'dnf clean packages'.
>> Error: Transaction check error:
>>    file /usr/lib64/libz.so.1.2.7 from install of zlib-1.2.7-18.el7.x86_64
>> conflicts with file from package zlib-1.2.7-17.el7.x86_64
> You have to cleanup duplicate packages. package-cleanup from yum-utils
> will do this job.
> Basically:
> package-cleanup --dupes
> will list the duplicate packages
> package-cleanup --cleandupes
> will remove the dupes. If I remember correctly, you have to add
> --removenewestdupes to the second command.
> Best regards
> Ulf
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> https://lists.centos.org/mailman/listinfo/centos
That didn't seem to work.  It did remove duplicates, however, I get the same error when running dnf update. Should I try it without the --removenewestdupes?