[CentOS] New post message

Wed Apr 3 09:15:58 UTC 2019
Konstantin Msk <konstantin_msk at mail.ru>


On my server PC i have Centos 7 installed.
CentOS Linux release 7.6.1810.
There are four arrays RAID1 (software RAID)
md124 - /boot/efi
md125 - /boot
md126 - /bd
md127 - /

I have configured booting from both drives, everything works fine if both drives are connected.
But if I disable any drive from which RAID1 is built the system crashes, there is a partial boot and as a result the Entering emergency mode.
By all rules RAID1 in case of similar failure of one of disks the system has to recognize this moment at loading, analyze that from the array only one disk is available and forcibly assemble inactive RAID array in case it is degraded in the mode when the second disk is missing may be...
In Debian system this problem does not occur, the initramfs runs the script /scripts/local-block/mdadm builds the array from one dostoinogo disc ( lack of drive is not important, it's either a drive failure or disconnection from power-random or not random).
In this script You can see the following
if [ "$COUNT" = "$MAX" ]
# Poor man's mdadm-last-resort at .service for incremental devices
mdadm -q --run /dev/md?*
# And last try for all others
mdadm -q --assemble --scan --run
rm -f /run/count.mdadm.initrd

Why in server Centos 7 this problem is still not solved?
Will this be fixed in upcoming releases?

Best Regards