[CentOS] Bacula 9.4.1 Dbdriver issue

Mon Jan 28 11:53:40 UTC 2019
J. Echter <j.echter at echter-kuechen-elektro.de>

Am 25.01.19 um 13:13 schrieb Alessandro Baggi:
> Hi list,
> I created my rpm for Bacula 9.4.1 reading centos srpm spec files. I 
> made a single package and not split in several packages because this 
> is my first rpm so I created my spec file taking a cue from bacula-5.3 
> spec file.
> All works as intended, an rpm was created and installed without any 
> not fixable issue.
> After installing my bacula rpm I run a test to see if all works as 
> expected. After bacula-dir and bacula-sd configuration I run 
> bacula-dir -t to check error in config file and get this message:
> bacula-dir: dird.c:1206-0 Dbdriver field within director config file 
> "dbi:PostgreSQL" mismatched with the Database argument "PostgreSQL" 
> passed during Bacula compilation.
> I don't know what it is referring because I don't pass any argument 
> like "PostgreSQL" during configure. The only option about postgresql 
> is --with-postgresql.
> This is caused by this line in catalog statement:
> dbdriver = "dbi:postgresql";
> I tried also using "dbi:PostgreSQL" but I got the same issue.
> I searched online but found only one fedora bugreport with the same 
> problem related to fedora29 but for a different bacula version.
> Over this I tried to run bacula and all works like expected.
> How I can fix this warning?
> Hope in help.
> Thanks in advance.
> Alessandro.
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> https://lists.centos.org/mailman/listinfo/centos


i got only

   dbdriver = "postgresql"

in my config file.