[CentOS] Signature Pad (Evolis Signotec Sig100)

Wed Jan 30 02:22:39 UTC 2019
Gregory P. Ennis <PoMec at PoMec.Net>


On 29-01-19 23:16, Gregory P. Ennis wrote:
> Everyone,
> Please forgive me for being off topic and really off list !!!
> I am trying to get a Sig100 signature pad to work with Centos 7.6 machine and am not
> getting much support from the manufacturer.  The product is sold as linux compatible, but
> so far it is not.  I have been able to download their software on a microsoft system and
> see that the unit does work on microsoft.
> My question to everyone on the list is have any of you had any brand of signature pad
> work
> with Centos 7.6?  If so I would surely appreciate knowing the brand and how you did it.
> I have been able to get a HUION H610PRO wacom to easily work with Centos 7.6, but the use
> of this for a production application for signatures will not really work easily for a
> user.
> Any ideas?

Nope but I found these links:

There's a signoPAD-API JAVA SDK. Try that on the CentOS box?
See https://en.signotec.com/download/sdk-api/signopad-api/

There's also a WebSocket Pad Server for Linux.
See https://en.signotec.com/download/sdk-api/websocket-pad-server/

CentOS mailing list
CentOS at centos.org


Thanks much for your help.  I had tried the links you listed above and in both cases the
scripts do not identify the signature pad as been attached to the system.  I have tried
this with both a kvm guest and a kvm host.  In all cases their software does not recognize
the presence of the signature pad.  I have not been able to get the manufacturers to
respond other than to acknowledge I have sent them a request for help. 


It is interesting in that the results of lsusb on the host demonstrate the device is
connected as :

Bus 001 Device 029: ID 2133:0001

But the descriptor of the device is missing

When I used lsusb on the guest of the hypervisor it is not present at all


CentOS mailing list
CentOS at centos.org