[CentOS] No network on cloned CentOS 7 installation

Fri May 3 16:48:30 UTC 2019
Nicolas Kovacs <info at microlinux.fr>


I have a few identical Dell Optiplex 7010 machines that I want to use
for our school's computer room. I tried to clone these installations
(like I did before on CentOS 5 and various versions of Slackware), but
this time I ran into a problem.

Here's what I did.

1. Install one computer and zero unused hard disk sectors with dd.

2. Send the image to a local FTP server using G4L (Ghost4Linux).

3. Fetch the image on another computer.

4. Boot the new computer in rescue mode and change the hardcoded
/etc/hostname to a new value.

Let me add that I removed all hardcoded MAC addresses from
/etc/sysconfig/ifcfg-em1, which has only very limited information in it.

What else could cause the network to choke on a cloned installation?


Microlinux - Solutions informatiques durables
7, place de l'église - 30730 Montpezat
Site : https://www.microlinux.fr
Mail : info at microlinux.fr
Tél. : 04 66 63 10 32
Mob. : 06 51 80 12 12