[CentOS] Diskless Centos & Cgroup config changes

Wed May 29 20:17:51 UTC 2019
Rory Falloon <rfalloon at gmail.com>


I have  OS 'image' that boots via PXE and mounts over NFS. (7.5.1804). I am
wanting to explore allowing cgroup usage on this configuration.

The root image is exported read-only over NFS and am using statetab & rwtab
to allow some persistent parts of the filesystem as well as read/write
where needed.

I have tried setting /sys in the statetab and this causes the machine to
fail, as I have tried /sys in the rwtab. The latter increases the boot time
to a point which is not usable. Trying /sys/fs/cgroup in rwtab seems to
improve boot time but also causes the machine not to complete booting.

I had some more success using cgconfig.conf, I was able to mount the memory
cgroup to a local disk (each node has a local temp disk) and manipulate
this using cgcreate but the cpu would not mount in the same fashion; the
error was: Error: cannot mount cpu to /var/tmp/cgroup/cpu: Device or
resource busy

So my question; in this particular environment, is how best to utilize
cgroup if I want control over both cpu and mem? Is it possible with a
read-only root image?