[CentOS] C8 and NetworkManager problem

Alessandro Baggi

alessandro.baggi at gmail.com
Wed Nov 20 09:37:08 UTC 2019

Hi list,

I've installed C8 on my workstation. I configured my network devices 
(two bridges, two nics) using nmcli. Now that NM is the default I tried 
it. On C7 I always disabled it.

I noticed some problem:

1) During the boot, also if NetworkManager-wait-online.service status is 
OK, I noticed that opening a terminal and ping some address it needs 
some time to perform ping and any operation on a network connection. So 
seems that in the first 30sec/1min there isn't an available network 
connection. After this time if I run a ping or whatever network is 

2) Due to the problem 1, It cannot mount samba shares on boot saying 
"Not suitable address found". After the network is available I can mount 
samba shares.

3) I noticed that with NetworkManager a bridge must have an address. If 
I don't specify an address for the bridge, NM will try to assign some 
address, enable the connection  forever (reporting errors in messages 
and on notification bar).

4) NetworkManager-wait-online slow down  boot time and network availability.

To solve this problem I installed network-scripts and disabled 
NetworkManager but I don't understand why NetworkManager need so much 
time to enable a connection.

Can someone point me in the right direction?

Thanks in advance.

More information about the CentOS mailing list