[CentOS] CentOS 8: what changed (regular UNIX admin commands)?

Tue Oct 22 18:11:04 UTC 2019
David G. Miller <dave at davenjudy.org>

On 10/22/19 10:55 AM, Valeri Galtsev wrote:
> Hello Experts!
> I'm sure many of you run CentOS for some time already.
> My question is: is there some place that lists which of the most often 
> used sysadmin commands are gone and what are replacements for them. Or 
> what else one needs to do after successful installation. (in the past 
> it was process accounting that was not enabled by default, but which 
> gives you quite some handle in investigating compromise).
> I just tried quite ordinaly command of freshly installed CentOS 8:
> last
> and got an error:
> last: (default utx db): No such file or directory
> I realize that it could be just me, and I'll cope with that myself one 
> way or another but this one prompted me to ask everybody: Is there 
> anything I can read so I can learn what differenmt to expect on CentOS 
> 8 from, say, CentOS 7?
> Thanks.
> Valeri
> ++++++++++++++++++++++++++++++++++++++++
> Valeri Galtsev
> Sr System Administrator
> Department of Astronomy and Astrophysics
> Kavli Institute for Cosmological Physics
> University of Chicago
> Phone: 773-702-4247
> ++++++++++++++++++++++++++++++++++++++++
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> https://lists.centos.org/mailman/listinfo/centos
Saw your later response that the problem was solved but this is an 
interesting question that deserves an answer (and not just what changed 
in RHEL8).  As an example, I'm used to ifconfig and route but keep 
getting reminded that these commands are now deprecated and "ip" should 
be used instead.  Likewise for using dnf instead of yum, systemctl 
instead of service, firewallcmd instead of iptables, etc. I wonder how 
many shell scripts there are "out there" that folks have written or 
accumulated over the years and which now need to be updated before 
deprecated becomes no longer available?  Or, like using iptables instead 
of firewallcmd, may cause something very different than what is expected.

Anyone know of any resource out there that might provide such documentation?


"They that can give up essential liberty to obtain a little temporary safety deserve neither safety nor liberty."

-- Benjamin Franklin