[CentOS] Wonky Firefox 68.0.1esr upgrade

Tue Oct 29 17:12:58 UTC 2019
Kay Schenk <kay.schenk at gmail.com>

Problem solved from kuna236 on Reddit discussion...(see comments)


FYI. For just testing, I copied my new firefox.desktop from 
/usr/local/share/applications to my local Desktop folder, and gave it a 
new name. Did not do the update-desktop-database yet. (Original 
firefox.desktop file in /usr/share/applications.) All good!

--- details from kuna236---

For anyone else out there trying to modify their |.desktop| file, I 
copied my |/usr/share/applications/firefox.desktop| to 
|/usr/local/share/applications/| and prepended |env GTK_IM_MODULE=xim| 
to the |Exec=| lines.

|Exec=env GTK_IM_MODULE=xim firefox %u |

Then ran |sudo update-desktop-database|.

I struggled for a little while because I forgot to include |env| in my 
|Exec|, and Firefox stopped showing up in my applications menu. Figured 
I'd post it here in case anyone else was making the same mistake.

-- end details --

"And in the end, only kindness matters."
    -- Jewel, "Hands"

On 10/26/19 3:09 PM, Kay Schenk wrote:
> Apparently, this is a "known" FF issue...
> https://support.mozilla.org/en-US/questions/1264837
> "And in the end, only kindness matters."
>     -- Jewel, "Hands"
> ______
>   MzK
> On 10/24/19 10:19 AM, Kay Schenk wrote:
>> I just applied a bunch of updates to my CentOS 7 system yesterday, 
>> one of which was a Firefox update to 68.0.1esr.
>> Now when I bring up sites I would log in to -- my bank, credit cards, 
>> etc., the Password box is wonky and shakes and doesn't display 
>> successive dots  for characters I type, nor does it accept what I 
>> type. My work around currently is to type the password first, then my 
>> userid but ???!!!!! Using either a <tab> to get to the Password box 
>> or just a click in the Password box causes the same results.
>> Previous Firefox version which worked fine 
>> --firefox-60.8.0-1.el7.centos.x86_64
>> HELP!