[CentOS] CentOS-6 cannot get kvm guest to start - network error

Tue Oct 1 15:03:03 UTC 2019
James B. Byrne <byrnejb at harte-lyne.ca>

Need to start a virtual machine but missing nic is preventing this:

I have need to recover some data from a guest on host which has been
shutddown for some time.  The host had one of it nic removed at some
point.  It is not likely to be replaced either.

When I try to start the guest in question I get this:

error: Failed to start domain inet09.harte-lyne.ca
error: Cannot get interface MTU on 'br1': No such device

I tried editing (virsh edit guest) to remove the interface:

    <interface type='bridge'>
      <mac address='52:54:00:35:a2:8a'/>
      <source bridge='br1'/>
      <model type='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x08'

I saved the changes and tried to start the guest. but I got the same
error.  Then edited the guest config to say:

    <interface type='network'>
      <mac address='52:54:00:35:a2:8a'/>
      <source network='default'/>
      <model type='virtio'/>

How do I configure this guest so it will start without the missing nic?

***          e-Mail is NOT a SECURE channel          ***
        Do NOT transmit sensitive data via e-Mail
 Do NOT open attachments nor follow links sent by e-Mail

James B. Byrne                mailto:ByrneJB at Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3