[CentOS] nextcloud-client currently not installable from EPEL in CentOS7

Kay Diederichs kay.diederichs at uni-konstanz.de
Mon Sep 2 14:43:53 UTC 2019


Dear all,

after enabling the EPEL repository,

[root at localhost ~]# yum install nextcloud-client

in a freshly installed and updated CentOS 7.6 machine gives

Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: centos.bio.lmu.de
 * epel: ftp.uni-stuttgart.de
 * extras: centos.schlundtech.de
 * updates: mirror1.hs-esslingen.de
Resolving Dependencies
--> Running transaction check
---> Package nextcloud-client.x86_64 0:2.3.3-1.el7 will be installed
--> Processing Dependency: nextcloud-client-libs(x86-64) = 2.3.3-1.el7
for package: nextcloud-client-2.3.3-1.el7.x86_64
--> Processing Dependency: libQt5WebKitWidgets.so.5(Qt_5)(64bit) for
package: nextcloud-client-2.3.3-1.el7.x86_64
--> Processing Dependency: libQt5Solutions_LockedFile-2.4.so.1()(64bit)
for package: nextcloud-client-2.3.3-1.el7.x86_64
--> Processing Dependency:
libQt5Solutions_SingleApplication-2.6.so.1()(64bit) for package:
nextcloud-client-2.3.3-1.el7.x86_64
--> Processing Dependency: libQt5WebKit.so.5()(64bit) for package:
nextcloud-client-2.3.3-1.el7.x86_64
--> Processing Dependency: libQt5WebKitWidgets.so.5()(64bit) for
package: nextcloud-client-2.3.3-1.el7.x86_64
--> Processing Dependency: libnextcloudsync.so.0()(64bit) for package:
nextcloud-client-2.3.3-1.el7.x86_64
--> Processing Dependency: libocsync.so.0()(64bit) for package:
nextcloud-client-2.3.3-1.el7.x86_64
--> Processing Dependency: libqt5keychain.so.1()(64bit) for package:
nextcloud-client-2.3.3-1.el7.x86_64
--> Running transaction check
---> Package nextcloud-client-libs.x86_64 0:2.3.3-1.el7 will be installed
---> Package qt5-qtwebkit.x86_64 0:5.9.1-2.el7 will be installed
--> Processing Dependency: qt5-qtbase(x86-64) = 5.9.7 for package:
qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Processing Dependency: qt5-qtdeclarative(x86-64) = 5.9.7 for
package: qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Processing Dependency: libQt5Positioning.so.5(Qt_5)(64bit) for
package: qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Processing Dependency: libQt5Qml.so.5(Qt_5)(64bit) for package:
qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Processing Dependency: libQt5Quick.so.5(Qt_5)(64bit) for package:
qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Processing Dependency: libQt5Quick.so.5(Qt_5_PRIVATE_API)(64bit) for
package: qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Processing Dependency: libQt5Sensors.so.5(Qt_5)(64bit) for package:
qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Processing Dependency: libQt5WebChannel.so.5(Qt_5)(64bit) for
package: qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Processing Dependency: libQt5Positioning.so.5()(64bit) for package:
qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Processing Dependency: libQt5Qml.so.5()(64bit) for package:
qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Processing Dependency: libQt5Quick.so.5()(64bit) for package:
qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Processing Dependency: libQt5Sensors.so.5()(64bit) for package:
qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Processing Dependency: libQt5WebChannel.so.5()(64bit) for package:
qt5-qtwebkit-5.9.1-2.el7.x86_64
---> Package qtkeychain-qt5.x86_64 0:0.7.0-1.el7 will be installed
--> Processing Dependency: qtkeychain(x86-64) = 0.7.0-1.el7 for package:
qtkeychain-qt5-0.7.0-1.el7.x86_64
---> Package qtlockedfile-qt5.x86_64 0:2.4-20.20150629git5a07df5.el7
will be installed
---> Package qtsingleapplication-qt5.x86_64 0:2.6.1-28.el7 will be installed
--> Running transaction check
---> Package qt5-qtdeclarative.x86_64 0:5.9.2-1.el7 will be installed
--> Processing Dependency: libQt5XmlPatterns.so.5(Qt_5)(64bit) for
package: qt5-qtdeclarative-5.9.2-1.el7.x86_64
--> Processing Dependency: libQt5XmlPatterns.so.5()(64bit) for package:
qt5-qtdeclarative-5.9.2-1.el7.x86_64
---> Package qt5-qtlocation.x86_64 0:5.9.2-1.el7 will be installed
---> Package qt5-qtsensors.x86_64 0:5.9.2-1.el7 will be installed
---> Package qt5-qtwebchannel.x86_64 0:5.9.2-1.el7 will be installed
---> Package qt5-qtwebkit.x86_64 0:5.9.1-2.el7 will be installed
--> Processing Dependency: qt5-qtbase(x86-64) = 5.9.7 for package:
qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Processing Dependency: qt5-qtdeclarative(x86-64) = 5.9.7 for
package: qt5-qtwebkit-5.9.1-2.el7.x86_64
---> Package qtkeychain.x86_64 0:0.7.0-1.el7 will be installed
--> Processing Dependency: libQtCore.so.4()(64bit) for package:
qtkeychain-0.7.0-1.el7.x86_64
--> Processing Dependency: libQtDBus.so.4()(64bit) for package:
qtkeychain-0.7.0-1.el7.x86_64
--> Running transaction check
---> Package qt.x86_64 1:4.8.7-3.el7_6 will be installed
--> Processing Dependency: qt-settings for package:
1:qt-4.8.7-3.el7_6.x86_64
---> Package qt5-qtwebkit.x86_64 0:5.9.1-2.el7 will be installed
--> Processing Dependency: qt5-qtbase(x86-64) = 5.9.7 for package:
qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Processing Dependency: qt5-qtdeclarative(x86-64) = 5.9.7 for
package: qt5-qtwebkit-5.9.1-2.el7.x86_64
---> Package qt5-qtxmlpatterns.x86_64 0:5.9.2-1.el7 will be installed
--> Running transaction check
---> Package qt-settings.noarch 0:19-23.8.el7.centos will be installed
---> Package qt5-qtwebkit.x86_64 0:5.9.1-2.el7 will be installed
--> Processing Dependency: qt5-qtbase(x86-64) = 5.9.7 for package:
qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Processing Dependency: qt5-qtdeclarative(x86-64) = 5.9.7 for
package: qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Finished Dependency Resolution
Error: Package: qt5-qtwebkit-5.9.1-2.el7.x86_64 (epel)
           Requires: qt5-qtbase(x86-64) = 5.9.7
           Installed: qt5-qtbase-5.9.2-3.el7.x86_64 (@anaconda)
               qt5-qtbase(x86-64) = 5.9.2-3.el7
Error: Package: qt5-qtwebkit-5.9.1-2.el7.x86_64 (epel)
           Requires: qt5-qtdeclarative(x86-64) = 5.9.7
           Available: qt5-qtdeclarative-5.9.2-1.el7.x86_64 (base)
               qt5-qtdeclarative(x86-64) = 5.9.2-1.el7
Error: Package: qt5-qtwebkit-5.9.1-2.el7.x86_64 (epel)
           Requires: qt5-qtdeclarative(x86-64) = 5.9.7
           Installing: qt5-qtdeclarative-5.9.2-1.el7.x86_64 (base)
               qt5-qtdeclarative(x86-64) = 5.9.2-1.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root at localhost ~]#

The culprit appears to be the current qt5-qtwebkit-5.9.1-2 from EPEL. A
workaround is: downloading and installing qt5-qtwebkit-5.9.1-1  (from
https://archive.fedoraproject.org/pub/archive/epel/7/x86_64/Packages/ )
lets the installation succeed. However, /etc/yum.conf then needs
exclude=qt5-qtwebkit

I think this is is due to the fact that EPEL is synchronized with RedHat
(which has version 7.7), but CentOS is still at 7.6

This type of problem has bitten us a couple of times (mostly with ElRepo
and the NVidia kmod and driver) - whenever a CentOS update was not yet
ready, but the corresponding RedHat point release was out.

ElRepo seems to have an elegant solution for this solution -
yum-plugin-elrepo .

Is there anything like that available for EPEL ?

thanks,
Kay



More information about the CentOS mailing list