[CentOS] ***UNCHECKED*** clamd / amavisd missing socket

Laurent Wandrebeck l.wandrebeck at quelquesmots.fr
Mon Sep 9 08:22:21 UTC 2019


Le vendredi 30 août 2019 à 13:57 -0400, Jon LaBadie a écrit :
> I think something along these lines appeared before
> but I was unable to find them.
> 
> I'm on a 7.6 system, been running clamav and amavisd-new
> since 6 days with little problem.  On a recent reboot,
> clamd at amavisd does not start up and fails manual start.
> 
> The problem seems to be the missing socket that connects
> the pair, "/var/run/clamd.amavisd/clamd.socket".
> 
> I believe this should be created by systemd files but I
> see no indication of them on my system.
> 
> Anyone know which files might be missing and where to
> get copies?  Or a work around to run clamd at amavisd
> and get rid of the "*** UNCHECKED ***' additions to my
> my Subject lines?
> 
> BTW manual creation of the socket with netcat had no effect
> on the startup.
> 
> Jon

Hi John,

I have the same problem, though /var/run/clamd.amavisd/clamd.sock do
exists (please note .sock and not .socket).

Sep 09 08:19:37 minicloud2 amavis[9597]: (09597-02) (!)connect to /var/run/clamd.amavisd/clamd.sock failed, attempt #1: Can't connect to a UNIX socket /var/run/clamd.amavisd/clamd.sock: Connection refused

ll /var/run/clamd.amavisd/clamd.sock
srw-rw-rw-. 1 amavis amavis 0 Jun 22 06:05 /var/run/clamd.amavisd/clamd.sock

Nothing denied in SELinux logs.

Don’t really know what the problem is for now, and have not yet found a
way to fix it, sorry.
-- 
Laurent Wandrebeck <l.wandrebeck at quelquesmots.fr>



More information about the CentOS mailing list