[CentOS] Need to update gcc to version >=6 on CentOS 7 ?

John Chludzinski john.chludzinski at gmail.com
Wed Sep 11 16:05:06 UTC 2019


I need to build u-boot on my CentOS 7 machine but encounter this:

> *** Your GCC is older than 6.0 and is not supported

I've updated the installation on my machine but the current version is:
> gcc (GCC) 4.8.5 20150623 (Red Hat 4.8.5-36)

How do I go about updating gcc to version 6 or greater on my CentOS 7
machine? And do so safely?


More information about the CentOS mailing list