[CentOS] C8.1 Grub problem

Mon Apr 6 13:21:38 UTC 2020
Simon Matter <simon.matter at invoca.ch>

> Il 06/04/20 11:54, Georgios ha scritto:
>> Hi there!
>> I had a similar problem recently with grub. No idea why it doesnt work.
>> Try using grubby instead of grub2-mkconfig if you want the system to
>> keep your kernel parameters between boots.
>> Something like:
>> sudo grubby --args="i915.modeset=0 rd.driver.blacklist=i915" --update-
>> kernel=ALL
>> Hope it helps!
>> Have a nice day!
>> On Mon, 2020-04-06 at 11:42 +0200, Alessandro Baggi wrote:
>>> Hi list,
>>> I reinstalled on my workstation CentOS 8.1.
>>> I explain: I'm a KDE user but packages shipped from EPEL currently
>>> are
>>> buggy so I prefer a stable and functioning system to work with. So I
>>> tried to remove KDE workgroup and installed group "Workstation" but
>>> the
>>> system bricked so I reinstalled with GNOME.
>>> I've an nvidia gtx 1050ti GPU so I installed kmod-driver from
>>> rpmfusion.
>>> After the installation of Nvidia driver, I rebooted, gdm start and
>>> after
>>> I perform the login the system freeze. So this problem happened to
>>> me
>>> with C7.5 and nvidia driver. In my case I need to blacklist i915
>>> module
>>> and system works.
>>> Also in this case I tried to boot centos changing grub kernel
>>> parameters
>>> pressing 'e' in the grub menu and adding "i915.modeset=0
>>> rd.driver.blacklist=i915", booted and system works.
>>> So I tried to make this permanent updating grub configuration adding
>>> the
>>> previous directives (and removed rhgb and quiet) to
>>> /etc/default/grub
>>> and run grub2-mkconfig -o /boot/efi/EFI/centos/grub.cfg.
>>> Reboot the system and checked again kernel parameters on grub menu
>>> and
>>> seen that nothing changed. Booted and freezed.
>>> I checked /boot/efi/EFI/centos/grub.cfg and kernelops has the new
>>> directives.
>>> Seems that grub configuration does not take effect.
>>> I made another test inside a VM installed with minimal selection and
>>> remove rhgb and quiet parameters and worked fine. The vm is BIOS and
>>> my
>>> workstation UEFI.
>>> How I can solve this problem? Currently to boot my system I need
>>> always
>>> to add this params.
>>> Thank you in advance
>>> _______________________________________________
>>> CentOS mailing list
>>> CentOS at centos.org
>>> https://lists.centos.org/mailman/listinfo/centos
>> _______________________________________________
>> CentOS mailing list
>> CentOS at centos.org
>> https://lists.centos.org/mailman/listinfo/centos
> Hi,
> I tried as suggested, parameters will be updated but I get already
> crash. So I tried to remove also rhgb and quiet and works well.
>   Would be good to know what is wrong with grub2-mkconfig.
> Where start to investigate?

Just to be sure, your subject line says this is on CentOS 8.1, right?

Because IIRC grub2-mkconfig was broken in CentOS 7 despite the head of
every grub cfg file telling us "It is automatically generated by
grub2-mkconfig using templates".

Really weird that you see the same with CentOS 8.1.