[CentOS] CentOS repo question

Thu Apr 23 14:29:47 UTC 2020
Johnny Hughes <johnny at centos.org>

On 4/22/20 9:38 AM, Tony Molloy wrote:
> On Wed, 2020-04-22 at 08:25 -0500, johnny at centos.org wrote:
>> EXTERNAL EMAIL: This email originated from outside of the University
>> of Limerick. Do not click on links or open attachments unless you
>> recognize the sender's email address and know the content is safe.
>> On 4/21/20 2:09 PM, Tony Molloy wrote:
>>> Hi All,
>>> I've just installed a test laptop with CentOS Stream 8.1.
>>> I notice that the default install has both CentOS-Base and
>>> CentOS-Base-Appstream repos enabled. Is that necessary, or should I
>>> just have the Appstream repos enabled.
>>> The reason I'm asking is because I'm having trouble updating the
>>> installation. The problem seems to be some installed rpms seem to
>>> depend on updates from the CentOS-Base repos and others seem to
>>> depend
>>> on similar updates from the CentOS-Base-Appstream repos and you
>>> can't
>>> install both.
>>> A typical error looks like this.
>>> cannot install both qt5-qttools-common-5.12.5-1.el8.0.1.noarch and 
>>> qt5-qttools-common-5.11.1-9.el8.noarch
>>> qt5-qttools-common-5.11.1-9.el8.noarch is from CentOS-Base
>>> qt5-qttools-common-5.12.5-1.el8.0.1.noarch is from
>>> CentOS-Base-Appstream
>>> So updating some installed rpm depends on updating to the Appstream
>>> version of qt5-qttools and some other installed rpm depends on the
>>> original CentOS-Base version of qt5-qttools.
>>> I've played around with --allowerasing --best and --nobest but
>>> still
>>> can't get a clean update.
>> We are working out Stream issues right now .. but no, it is not
>> necessary to have all the repos active.  You only have to have one
>> set
>> of Base, Appstream, and Extras enabled (CentOS Stream or CentOS
>> Linux).
>> Stream standup is very much a work in progress at this point , but it
>> is
>> what i am using as my personal workstation (for whatever that is
>> worth).
>> You SHOULD be able to have both sets enabled though .. and will be
>> able
>> to once we have all the issues solved .. but i don't have them both
>> enabled on my workstation right now, just CentOS Stream.
>> Thanks,
>> Johnny Hughes
> Thanks Johnny. I'll go with the Stream repos enabled and see how that
> works out.

For the record .. i just updated to what we have in the QA stream and it
worked OK .. I expect that out soon (next day or so i think)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 195 bytes
Desc: OpenPGP digital signature
URL: <http://lists.centos.org/pipermail/centos/attachments/20200423/a3fbd99a/attachment-0005.sig>