[CentOS] Weird bug in 389 Directory Server : no spaces in admin console (CentOS 7)

Sun Apr 26 09:43:31 UTC 2020
Nicolas Kovacs <info at microlinux.fr>

Le 26/04/2020 à 08:45, Nicolas Kovacs a écrit :
> 100 % positive.
> I tried it on a different sandbox server without X installed, but only with
> xorg-x11-xauth.
> From my workstation running OpenSUSE Leap 15.1, I connected to my admin console
> using the following command:
> $ ssh -X microlinux at /usr/bin/389-console -a
> And I have the same problem here. When I try to fill out the "UserID" field
> with "cn=Directory Manager", I can't put in a space after "cn=Directory". I can
> hit the space bar as much as I want, the cursor won't budge.
> I'm puzzled.

I investigated this some more. Here's what I found.

Installed a vanilla CentOS 7 GNOME desktop.

Activated EPEL and installed 389-ds.

Launched the setup script for 389 DS.

Works perfectly bot locally and from my remote workstation with ssh -X.

So far, so good.

Back in 2019 I ran 389 DS on a minimal CentOS 7 installation. Installed 389-ds
from EPEL, installed xorg-x11-xauth, and then opened the graphical admin
console from my workstation.

But when I do this now, I can't seem to use spaces in the admin console's input

Any suggestions ?

Microlinux - Solutions informatiques durables
7, place de l'église - 30730 Montpezat
Site : https://www.microlinux.fr
Mail : info at microlinux.fr
Tél. : 04 66 63 10 32
Mob. : 06 51 80 12 12