[CentOS] C8.1 Grub problem

Mon Apr 6 09:42:58 UTC 2020
Alessandro Baggi <alessandro.baggi at gmail.com>

Hi list,

I reinstalled on my workstation CentOS 8.1.

I explain: I'm a KDE user but packages shipped from EPEL currently are 
buggy so I prefer a stable and functioning system to work with. So I 
tried to remove KDE workgroup and installed group "Workstation" but the 
system bricked so I reinstalled with GNOME.

I've an nvidia gtx 1050ti GPU so I installed kmod-driver from rpmfusion. 
After the installation of Nvidia driver, I rebooted, gdm start and after 
I perform the login the system freeze. So this problem happened to me 
with C7.5 and nvidia driver. In my case I need to blacklist i915 module 
and system works.

Also in this case I tried to boot centos changing grub kernel parameters 
pressing 'e' in the grub menu and adding "i915.modeset=0 
rd.driver.blacklist=i915", booted and system works.

So I tried to make this permanent updating grub configuration adding the 
previous directives (and removed rhgb and quiet) to /etc/default/grub 
and run grub2-mkconfig -o /boot/efi/EFI/centos/grub.cfg.

Reboot the system and checked again kernel parameters on grub menu and 
seen that nothing changed. Booted and freezed.

I checked /boot/efi/EFI/centos/grub.cfg and kernelops has the new 

Seems that grub configuration does not take effect.

I made another test inside a VM installed with minimal selection and 
remove rhgb and quiet parameters and worked fine. The vm is BIOS and my 
workstation UEFI.

How I can solve this problem? Currently to boot my system I need always 
to add this params.

Thank you in advance