[CentOS] Weird bug in 389 Directory Server : no spaces in admin console (CentOS 7)

Sun Apr 26 05:41:38 UTC 2020
Nicolas Kovacs <info at microlinux.fr>


I'm currently setting up 389 Directory Server on a server running CentOS 7, and
I have a weird and somehow showstopping bug.

All the spaces are suddenly missing in the admin console. Here's a screenshot
so you can get the idea :


So instead of "Standard branch for configuration information", I get
"Standardbranchforconfigurationinformation", "Secure connection" reads
"Secureconnection", etc.

I tried to add a user in my directory, with "Nicolas Kovacs" in the "Common
Name" field, but instead of "Nicolas Kovacs" I get "NicolasKovacs" and there is
no way to add space between the first and the last name.

Last year I made the same setup and even wrote a series of blog articles about
389 DS on CentOS 7, and everything worked perfectly. Here's the screenshot from
last year's setup:


Any idea what's going on here ?


Microlinux - Solutions informatiques durables
7, place de l'église - 30730 Montpezat
Site : https://www.microlinux.fr
Mail : info at microlinux.fr
Tél. : 04 66 63 10 32
Mob. : 06 51 80 12 12