[CentOS] GUI boot failure after latest shim (etc) updates

Mon Aug 3 01:54:03 UTC 2020
Fred Smith <fredex at fcshome.stoneham.ma.us>

This isn't the problem everyone else has been talking about, but...

I made sure that yum update offered the packages Johnny said it should
then updated. when I rebooted everything looked normal except it was
taking a long time to bring up the login screen.

Flipped over to ALT-F2 and saw a message about waiting for Plymouth
boot screen to quit. I waited a while and it went up to (and past)
15 minutes. It said "no limit" so it apparently would have gone on

I couldn't get to a text-mode screen with ALT-f[2-6] so I went down
to my Linux laptop to see if I could ssh into this box. Lo and behold,
ssh worked fine. So I ran top and saw a plymouth (or plymouthd, I
forget which) at the top of the list. killed it, came back upstairs
and it was no longer spewing that message.

now ALT-f2 gave me a text login, that I'm using now.

I ran startx and after a long-seeming wait I get a desktop, but it
is NOT my normal Mate desktop. Might be Gnome (since I installed
a Centos Gnome system and retrofitted Mate from EPEL).

Johnny had said we needed to make sure the kernel was installed
along with the shim, et al. I looked at the list of files YUM
wanted to install and saw some kernel files, so I assumed all
was well. But maybe I missed something.

What info can I provide to help figure this out? Or, what Kernel
files should I force to be (re)installed? 

Also, I don't very often manually force a kernel install, but I know
that some of the files are updates and some are installs, I'd appreciate
a reminder of which is which so I can force it.

Thanks in advance!

---- Fred Smith -- fredex at fcshome.stoneham.ma.us -----------------------------
                      The eyes of the Lord are everywhere, 
                    keeping watch on the wicked and the good.
----------------------------- Proverbs 15:3 (niv) -----------------------------