[CentOS] Update CentOS 6 one last time?

Tue Dec 8 22:07:25 UTC 2020
Richard <lists-centos at listmail.innovate.net>

> Date: Tuesday, December 08, 2020 13:25:42 -0800
> From: Paul Storck via CentOS <centos at centos.org>
>> On Tue, Dec 8, 2020 at 8:45 AM Subscriber <ml-lists at agoris.net.ua>
>> wrote:
>> > ----- On Dec 8, 2020, at 6:31 PM, Paul Storck wrote:
>> > Hello, is it possible to install the final updates for CentOS 6?
>> > I ran a yum update and I received this message "Error: Cannot
>> > find a valid baseurl for repo: base" I assume it's due to the
>> > EOL of CentOS 6?
>> You can add 6.10 section to /etc/yum.repos.d/CentOS-Vault.repo and
>> after that install all last updates for CentOS 6
> Thank you for the response. I added (copied, edited, pasted from
> the C6.9 section) the following to the
> /etc/yum.repos.d/CentOS-Vault.repo file but I still get the same
> error message.
> I'm thinking the paths are incorrect in my file because when I try
> to go to directly to the URL
> (http://vault.centos.org/6.10/os/$basearch/) I get a "404 Not Found"
> [C6.10-base]
> name=CentOS-6.10 - Base
> baseurl=http://vault.centos.org/6.10/os/$basearch/
> gpgcheck=1
> gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6
> enabled=1

When you tried the url directly did you make the necessary
substitutions for "$basearch"? It needs an architecture and then some
additional pathing to get to packages.

After adding the C6.10 entries to the Vault repo did you turn off the
entries (e.g., set "enabled=" to "0") in the non-vault repos? If you
don't yum will still try them. The CentOS-Base.repo is on by default
so you'll either need to add the "enabled=" line to each of the
entries or otherwise disable the repos.