[CentOS] [External] Re: Installing a single rpm package from desktop/browser on CentOS 7

Wed Feb 26 13:48:20 UTC 2020
Toralf Lund <toralf.lund at pgs.com>

On 24/02/2020 15:46, Pete Biggs wrote:
>> In many case, but in the situations I'm talking about here is really a
>> lot more cumbersome to use. To use the command line to install a a
>> package from a website, I have to
>>   1. Right-click
>>   2. Select Save Link As
>>   3. Enter filename/directory
>>   4. Open a terminal
>>   5. Remember where I put the bloody file
>>   6. Run yum to actually install it.
> yum (and rpm) can install from the web
> 1. Right-click
> 2. Copy link location
> 3. yum install <paste link location>

Yeah, I knew that, really. Still pretty annoying, though.

>> Compare that to
>>   1. Click on the link
>>   2. Hey, there's no step 2.
>> The 2nd variant is something that's was working for about 15 years, but
>> I guess that was before someone decided to make the system "user
>> friendly"...
> Without getting emotional about it you need to think what happens when
> you click on a link in a web browser, i.e. how does the browser know to
> install this link you've just clicked on and what does it have to do in
> order to install it. Personally, I think having RPMs installable with a
> single click is a bad idea - they are as dangerous as .exe on Windows
> systems.

Well, "yum install" with an URL isn't really any safer, is it?

I don't think packages should be installed without any extra 
interaction, of course. With the way it's worked for several years, you 
have to enter a password and confirm that you want to start 
installation, and there are possibly warnings/extra confirmation steps 
related to signatures, too...

>   Having said that, on my Fedora system clicking on an RPM
> downloads it (with a warnning), then double clicking on the downloaded
> RPM in the browser launches "Gnome Software" to install it: no
> terminals involved and you never have to take your hand off the mouse.
> Things may be different if you aren't using Gnome or it may be
> different for another browser.

I have concluded that it's meant to work that way in CentOS/Red Hat 
Enterprise 7, too. It's just that "Gnome Software" is seriously broken. 
Or more likely, the version included just wasn't ready for release, then 
someone released it anyway...

It's hard not to get emotional about that when you know there was a 
perfectly usable alternative in past versions, which basically means 
someone went out of their way to break a system that just worked.

- Toralf

> P.
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> https://urldefense.proofpoint.com/v2/url?u=https-3A__lists.centos.org_mailman_listinfo_centos&d=DwICAg&c=KV_I7O14pmwRcmAVyJ1eg4Jwb8Y2JAxuL5YgMGHpjcQ&r=Q0oqxzgUp3xCCIiJDwS-RbNDndQ-KZDhj8wwveNoqU4&m=eQAXNOd4oRL0Q1DPMezlKcdFNxSszG5oyM2dFFDJagA&s=EqEtj1TDcASGmA0gpz544HIs7E2hD8JhlG0HCtcbwSg&e=