[CentOS] CentOS 7 as a Fibre Channel SAN Target

Sat Jan 4 10:20:14 UTC 2020
Steffan Cline <steffan at hldns.com>

In waiting, I tried CentOS 8 which was an even bigger bust. I wiped that clean and tried again with Fedora 31. Same darn error "Could not create Target in configFS". 


Thank you,
Steffan Cline
steffan at hldns.com

On 1/2/20, 2:00 AM, "CentOS on behalf of Steffan Cline via CentOS" <centos-bounces at centos.org on behalf of centos at centos.org> wrote:

    It took me some time to come back full circle to this. I've worked quite a bit on this with little success so far. It seems like it's been done but on some of the forums and Github, there are no responses yet. This is essentially a cross post from a seemingly dead list. Hopefully someone here will have some suggestions.
    I've googled this particular issue and not really finding any good results on how to resolve it.
    I installed targetcli via yum on CentOS 7 and this is the version in the repo:
    # targetcli
    targetcli shell version 2.1.fb49
    Copyright 2011-2013 by Datera, Inc and others.
    For help on commands, type 'help'.
    I downloaded the .zip of the targetcli-fb version and tried it too from the scripts folder and same results.
    # python --version
    Python 2.7.5
    Installed Packages
    python-configshell.noarch 1:1.1.fb25-1.el7 @base
    python-rtslib.noarch 2.1.fb69-3.el7 @base
    python-rtslib-doc.noarch 2.1.fb69-3.el7 @base
    The error comes up when using create.
    /> /qla2xxx create naa.xxxxxxxxxxxxxxx
    Could not create Target in configFS
    Below is the info on my FC
    /> qla2xxx/ info
    Fabric module name: qla2xxx
    ConfigFS path: /sys/kernel/config/target/qla2xxx
    Allowed WWN types: naa
    Allowed WWNs list: naa.xxxxxxxxxxxxxxx, naa.xxxxxxxxxxxxxxx, naa.xxxxxxxxxxxxxxx, naa.xxxxxxxxxxxxxxx, naa.xxxxxxxxxxxxxxx, naa.xxxxxxxxxxxxxxx, naa.xxxxxxxxxxxxxxx, naa.xxxxxxxxxxxxxxx
    Fabric module features: acls
    Corresponding kernel module: tcm_qla2xxx
    I have attached the log but don't see anything that really stands out. log.txt
    I checked per the link http://www.linux-iscsi.org/wiki/Fibre_Channel#Enable_target_mode to ensure that I have initiator mode disabled
    # cat /sys/module/qla2xxx/parameters/qlini_mode
    The kernel modules are loaded.
    # lsmod | grep qla2xxx
    tcm_qla2xxx 32768 1
    target_core_mod 335872 4 tcm_qla2xxx,iscsi_target_mod
    qla2xxx 634880 1 tcm_qla2xxx
    scsi_transport_fc 65536 3 bfa,qla2xxx,tcm_qla2xxx
    configfs is mounted:
    # cat /proc/mounts | grep configfs
    configfs /sys/kernel/config configfs rw,relatime 0 0
    In the kernel config:
    Should I be able to create a directory in /sys/kernel/config/target/qla2xxxx?
    # mkdir naa.10008c7cffc7ef01
    mkdir: cannot create directory ‘naa.xxxxxxxxxxxxxxx’: Invalid argument
    I did notice that when I rebooted, there was no qla2xxx folder in /sys/kernel/config/target/ but after trying to use targetcli, it did make one so I'm not sure what else would cause it to fail.
    Thank you,
    Steffan Cline
    steffan at hldns.com
    On 1/11/19, 12:01 AM, "Steffan A. Cline" <steffan at hldns.com> wrote:
        For quite some time I’ve been using FreeNAS to provide services as a NAS over ethernet and SAN over Fibre Channel to CentOS 7 servers each using their own export, not sharing the same one.
        It’s time for me to replace my hardware and I have a new R720XD that I’d like to use in the same capacity but configure CentOS 7 as a Fibre Channel target rather than use FreeNAS any further.
        I’m doing virtualization and this will allow me to have failover from one node to the other since they’ll all be sharing the same export rather than me simply backing up to the FreeNAS server the way I am now.
        Does anyone know of any really good current articles that explain how to set up CentOS 7 as the target in such a configuration and also setting up CLVMd so they can all share an export over Fibre Channel from CentOS 7?
        Steffan A. Cline
        steffan at hldns.com
    CentOS mailing list
    CentOS at centos.org