[CentOS] Unresolved dependencies when upgrade on centOS 8

Sat Jan 11 11:02:28 UTC 2020
Phil Perry <pperry at elrepo.org>

On 11/01/2020 05:40, Ebed wrote:
> Hi,
> Guys i got unresolved dependencies when trying to upgrade centOS 8, what
> should i do to fix this?
> [root at ws1 ebedsat]# dnf upgrade
> Last metadata expiration check: 0:14:27 ago on Sat 11 Jan 2020 12:16:02 PM
> WIB.
> Error:
>   Problem 1: cannot install the best update candidate for package
> kmod-iwlegacy-0.0-1.el8.elrepo.x86_64
>    - nothing provides kernel >= 4.18.0-147.el8 needed by
> kmod-iwlegacy-0.0-2.el8_1.elrepo.x86_64
>    - nothing provides kernel(__pci_register_driver) = 0xe85eaefe needed by


> [root at ws1 ebedsat]# uname -mrs
> Linux 5.4.10-1.el8.elrepo.x86_64 x86_64

The kmod-iwlegacy package above is not compatible with 
kernel-5.4.10-1.el8.elrepo.x86_64 x86_64 that you are running. 
kmod-iwlegacy requires a disto kernel (kernel >= 4.18.0-147.el8 as 
indicated in the error message), so you either need to install the 
required distro kernel (although yum should pull it in as a dependency) 
or better yet, uninstall kmod-iwlegacy if you plan on running the 
updated elrepo kernel.

I'll leave someone else to address the qt-creator issue.