[CentOS] After update to 8 (2004) ... system is unbootable - UEFI Secure boot

Wed Jul 29 18:43:10 UTC 2020
Leon Fauster <leonfauster at googlemail.com>

Am 16.06.20 um 22:04 schrieb Fabian Arrotin:
> On 16/06/2020 15:06, Leon Fauster via CentOS wrote:
>> Hi all,
>> I updated a Dell XPS laptop from CentOS 8.1 (1911) to 8.2 (2004).
>> Installed kernels are
>> kernel-4.18.0-147.5.1.el8_1.x86_64
>> kernel-4.18.0-147.8.1.el8_1.x86_64
>> kernel-4.18.0-193.6.3.el8_2.x86_64
>> Unfortunately I can not boot into the latest
>> kernel-4.18.0-193.6.3.el8_2.x86_64.
>> After grub2 screen I only see following line:
>> EFI stub: UEFI Secure Boot is enabled
>> Booting into the older kernel is still possible. The
>> above line appears and after that the normal kernel
>> output scrolls over the screen (rhgb quiet disabled).
>> Is the new kernel correctly signed?
>> What can I do?
>> -- 
>> Thanks
>> Leon
> Hi Leon,
> Don't think that it's due to secureboot, as on my work laptop (thinkpad
> t490s), I have secureboot on, and kernel working fine.
> OTOH, on my family laptop (also in secureboot mode), when I updated from
> 8.1.1011 to 8.2.2004, laptop became unresponsive during the
> microcode_ctl update (in scriptlet) and after that it auto-reset itself
> , so in the middle of the whole rpm transaction.
> I tried to recover it but it was to a point where it was faster to just
> reinstall from scratch with 8.2.2004, which I did ... and in gnome,
> everything was fine, etc (adding repo, pkgs) but then on the *same*
> kernel it was installed with, just tried a reboot, and nothing  : grub
> shows menu, you select kernel and on upper left there is only cursor
> (fixed) and nothing happens ..
> I'll try to diagnose what's the issue as actually that means troubles
> with family using that laptop :)

Did you got managed to boot kernel-4.18.0-193.14.2.el8_2 or a newer one?
I must still boot into kernel-4.18.0-147.8.1.el8_1.x86_64 ... and with 
the upcoming new kernel that depends on a new shim and grub2 package I 
wonder about the implications for my XPS hardware ...