[CentOS] USB-serial adapter for CentOS 7

Wed Jul 8 16:25:06 UTC 2020
Leroy Tennison <leroy at datavoiceint.com>

-> "nobody uses RS232 anymore!"

Somebody needs to update the hand writing on the wall, although the physical hardware may be an RJ-45, the RS232 protocol is still used on headless devices and probably other things.  I use minicom more than I wish but it's still required.
From: CentOS <centos-bounces at centos.org> on behalf of mailist <mailist at toolz.com>
Sent: Wednesday, July 8, 2020 11:11 AM
To: CentOS mailing list <centos at centos.org>
Subject: [EXTERNAL] Re: [CentOS] USB-serial adapter for CentOS 7

CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you recognize the sender and know the content is safe.


Leroy Tennison
Network Information/Cyber Security Specialist
E: leroy at datavoiceint.com


2220 Bush Dr
McKinney, Texas

This message has been sent on behalf of a company that is part of the Harris Operating Group of Constellation Software Inc.

If you prefer not to be contacted by Harris Operating Group please notify us<http://subscribe.harriscomputer.com/>.

This message is intended exclusively for the individual or entity to which it is addressed. This communication may contain information that is proprietary, privileged or confidential or otherwise legally exempt from disclosure. If you are not the named addressee, you are not authorized to read, print, retain, copy or disseminate this message or any part of it. If you have received this message in error, please notify the sender immediately by e-mail and delete all copies of the message.

On 2020-07-08 11:28, Tate Belden wrote:
> I've several USB <-> RS-232 dongles around. As well as a few embedded
> devices. They all "Just Work (tm)" on Redhat, CentOS, Fedora, Debian,
> Raspian and Kali.

Even if you did have an RS232 port on the box, the serial drivers for
CentOS 7 have
never worked correctly.  I had an application using RS232 that worked
under CentOS 6, and then worked intermittently under CentOS 7, and
failed miserably
on CentOS 8.  The handwriting on the RedHat wall says, "nobody uses
RS232 anymore!"
I moved the app to a Raspberry Pi 3B+, using the USB serial adapters,
and it works
perfectly again.

Todd Merriman
Software Toolz, Inc.
CentOS mailing list
CentOS at centos.org