[CentOS] Brother HL-L2360DW printing quality

Thu Jul 23 01:20:10 UTC 2020
Fred Smith <fredex at fcshome.stoneham.ma.us>

On Wed, Jul 22, 2020 at 07:05:52PM -0400, H wrote:
> On 09/20/2019 08:27 PM, H wrote:
> > On 09/20/2019 09:02 AM, Stephen John Smoogen wrote:
> >> On Thu, 19 Sep 2019 at 20:23, H <agents at meddatainc.com> wrote:
> >>> I have the above printer but have not been able to resolve issues with the printing quality in CentOS 7. The test page prints fine but when I print PDF-documents, most recently using Chinese fonts, it is lacking and the pages very hard to read. The settings in the Mate Cups configuration panel are fine and set to 600 dpi, the settings in the printer menu are all OK yet it prints more like maybe 150 or even 75 dpi.
> >>>
> >> Warning: this advise is old and possibly out of date for how printer
> >> administration should be done these days.
> >>
> >> Usually when I run into this sort of issue it usually has to be fixed
> >> with an updated ppd driver from the vendor for that printer... usually
> >> the one they give to Apple and possibly one that was aimed for the
> >> country/area the language is not working on. I would then have to
> >> double set the printer with one for Western fonts and one for
> >> non-Western using 2 different ppds because things looked wrong one way
> >> or another. In looking at the ppd's it looked like they had the
> >> equivalent to microcode they sent the printer to update to do things
> >> 'better'. I can say the quality of printing was vastly different.
> >>
> >> The other item was just that some fonts look great on screen and dont'
> >> print well.. but I am guessing htis is one printer which is acting
> >> badly and others are doing well?
> >>
> >>
> >>> Any suggestion what might be wrong?
> >>>
> >>> _______________________________________________
> >>> CentOS mailing list
> >>> CentOS at centos.org
> >>> https://lists.centos.org/mailman/listinfo/centos
> >>
> > See my reply to Fred. Just checked the printer drivers for Linux on the Brother website (https://support.brother.com/g/b/downloadlist.aspx?c=us&lang=en&prod=hll2360dw_us&os=127) and it looks the drivers for Linux are from 2014 and 2015...
> >
> > The printer driver for Mac OS 10.14 is more recent from 2018 (https://support.brother.com/g/b/downloadlist.aspx?c=us&lang=en&prod=hll2360dw_us&os=10052) and that page also lists a firmware update tool with firmware from July of this year. The update history for the firmware refers only to "improvements" and "software bugs", not very helpful.
> >
> > Clearly I need to see if I can update the firmware. The most current firmware on the page above is 1.29 whereas my printer has 1.25. Annoyingly the firmware update instructions on this page refers to how to do the update on a Mac...
> >
> Closing out my problem above. I installed the driver on a new computer running CentOS 7 and had no problems printing. There must have been a misconfiguration of the driver on the old computer, or, less likely, the Brother driver had been updated on the Brother website.
> I am now a happy camper.

I've also noticed that the Brother drivers for Linux are quite old, I sent a support question
about it and they denied there being a problem with some sort of market-speak. 
Nevertheless, they have always worked for  me.

---- Fred Smith -- fredex at fcshome.stoneham.ma.us -----------------------------
                         God made him who had no sin
                      to be sin for us, so that in him
                 we might become the righteousness of God."
--------------------------- Corinthians 5:21 ---------------------------------