[CentOS] CentOS 8 vncserver

Thu Nov 12 14:56:04 UTC 2020
Jonathan Billings <billings at negate.org>

On Thu, Nov 12, 2020 at 09:12:42AM -0500, Jerry Geis wrote:
> I am trying to get vncserver working on CentOS 8. Fully updated.
> On the console - logged in as a normal user I run:
> export DISPLAY=:0.0
> xhost +
> /usr/bin/x0vncserver -display :0 -rfbport 5901 -passwordfile
> /home/silentm/.vnc/passwd
> I get this error:
> Invalid MIT-MAGIC-COOKIE-1 key/usr/bin/x0vncserver: unable to open display
> ":0"
> Based on the error I changed the DISPLAY=:0 and tried again - but same
> error.
> Am I doing something wrong?   I dont really need this to start as a service
> was just trying to start by hand.

Is there an X11 server running, listening on display :0.0?  It sounds
like you said you logged in on the console, that sounds like you
aren't running X yet, but are at the text console.

If you want to run vncserver, I suggest using the xvnc at .service
included in the package:


There are instructions in the comments.

Jonathan Billings <billings at negate.org>