[CentOS] Upgrading (?) from legacy boot to UEFI

Sat Aug 28 06:58:12 UTC 2021
Rob Kampen <rkampen at kampensonline.com>

On 27/08/21 10:51 pm, Rob Kampen wrote:
> Unfortunately the server is remote and the CentOS7 USB device I left 
> plugged into the machine refuses to boot from UEFI mode. Thus a rescue 
> mode boot has not been possible.
So i made a trip and replaced the USB stick with another one - CentOS7
> I am unsure what file I need to point the UEFI bios disk manager setup 
> at, I have tried shim.efi and shimx84-centos.efi
> The message I get is that linux16 and initrd16 cannot find their 
> files. The change to linuxefi and initrdefi also fail but the system 
> reboot happens before I can see what flashes on screen.
> Is a USB based UEFI booted rescue mode the only way I can fix this?

So I then rebooted - selected UEFI native boot and got into rescue mode 
- only problem is that the rescue system did not find a Linux system. 
Really weird as each of the four drives effectively have a complete 
centos7 system. No idea why it didn't start md raid and find the 6 raid1 

About to give this a miss and just live with legacy boot - this UEFI 
thing is just far too complicated. Looking on line at all the various 
blogs and questions it seems I am not alone in finding it far too 

I run a Ubuntu workstation that is UEFI based and their grub.cfg is so 
much simpler than the centos one.

> TIA for your pointers / suggestions.
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> https://lists.centos.org/mailman/listinfo/centos