[CentOS] centos 8 stream / last yum update / VirtualBox 6.1.26

Fri Aug 6 13:27:08 UTC 2021
Mathy Froeyen <mathy.froeyen at kuleuven.be>

Hi all

Till this morning, I ran Windows 10 client on VirtualBox 6.1.24 on host Centos 8 stream kernel 4.18.0-315.el8 without problem (desktop).

I took the risk to do a "yum update" and as well as the kernel as the VirtualBox were updated:
kernel going from 4.18.0-315.el8  to 4.18.0-326.el8
VirtualBox going from 6.1.24 to 6.1.26

But yum complained already :

Installing: Package             Arch        Version                  Repository       Size
 VirtualBox-6.1      x86_64      6.1.26_145957_el8-1      virtualbox       86 M
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Installing       : SDL-1.2.15-39.el8.x86_64                               1/2 
  Running scriptlet: SDL-1.2.15-39.el8.x86_64                               1/2 
  Running scriptlet: VirtualBox-6.1-6.1.26_145957_el8-1.x86_64              2/2 
  Installing       : VirtualBox-6.1-6.1.26_145957_el8-1.x86_64              2/2 
  Running scriptlet: VirtualBox-6.1-6.1.26_145957_el8-1.x86_64              2/2 

Creating group 'vboxusers'. VM users must be member of that group!

depmod: ERROR: fstatat(4, nvidia-drm.ko.xz): No such file or directory
depmod: ERROR: fstatat(4, nvidia-modeset.ko.xz): No such file or directory
depmod: ERROR: fstatat(4, nvidia-peermem.ko.xz): No such file or directory
depmod: ERROR: fstatat(4, nvidia-uvm.ko.xz): No such file or directory
depmod: ERROR: fstatat(4, nvidia.ko.xz): No such file or directory

  Verifying        : SDL-1.2.15-39.el8.x86_64                               1/2 
  Verifying        : VirtualBox-6.1-6.1.26_145957_el8-1.x86_64              2/2 
Installed products updated.

  SDL-1.2.15-39.el8.x86_64       VirtualBox-6.1-6.1.26_145957_el8-1.x86_64      


Vbox did not start my Windows 10 when I tried.

I also tried to install VirtualBox 6.0 and 5.2 with the same kind of error in yum.

I rebooted then the computer and started a previous kernel 4.18.0-310.el8 and reinstalled Virtualbox 6.1.26 now without those errors and it runs smooth as before. (Kernel 315 had the same vbox errors.)

However, when I went back to kernel 4.18.0-326 and tried starting there VirtualBox 6.1.26 again, he complained with :

Failed to open a session for the virtual machine Windows10.

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver is either not loaded or not set up correctly.
 Please try setting it up again by executing


as root.

(I tried that "/sbin/vboxconfig" but that tells me nonsense about registering because of EFI secure boot, but I did not change anything in the BIOS.)

or there is some conflict between the last kernels and VirtualBox?