[CentOS] Microsoft Teams on CentOS 7. Does the latest version work?

Fri Jul 16 08:41:23 UTC 2021
Simon Matter <simon.matter at invoca.ch>

> On 15/07/2021 12:57, Stephen John Smoogen wrote:
>> On Thu, 15 Jul 2021 at 05:30, Toralf Lund <toralf.lund at pgs.com> wrote:
>>> On 15/07/2021 09:37, Gianluca Cecchi wrote:
>>>> On Tue, Jul 13, 2021 at 2:03 PM Toralf Lund <toralf.lund at pgs.com>
>>>> wrote:
>>>>> Does anyone else run Microsoft Teams on CentOS 7?
>>>>> I've used it for a while now, and it's generally worked reasonably
>>>>> well.
>>>>> However, after upgrading to the latest version from the Microsoft
>>>>> repos,
>>>>> it doesn't start up properly. Processes start and remain active until
>>>>> I
>>>>> give up and kill them, but I can't see a window or a tray icon or
>>>>> anything.
>>>>> Has anyone else seen this? Is there anything I can do to make the GUI
>>>>> appear?
>>>>> This is not a big deal as everything just works fine if I revert to
>>>>> the
>>>>> previous release, but it would be interesting to know if this is a
>>>>> general problem with the software, or I have some weird issue with my
>>>>> system.
>>>>> The release that doesn't work is The one that does is
>>>>> - Toralf
>>>> At the end I think you have something broken with your repo config or
>>>> you
>>>> installed forcing something.
>>> Like I said elsewhere, it turns out that it's a little more complicated
>>> than that. The libraries are actually "provided", but they're not on
>>> the
>>> library path.
>> That isn't provided..
> It's quite definitely provided. I'm mean in the rpm/package install
> context, of course, which is what we were discussing.
> The libraries/abi versions are also provided in the sense that the
> actually exist on my system, event though teams can't find them right now.
>>   that is a private copy that chrome bundles
>> itself to use. It may or may not have all of the library calls in it
>> (the chrome upstream may only turn on things it knows it wants), and
>> it may have changes which the team doesn't expect.
> I think you're missing my point. The teams install works because the
> package *claims* that it provides everything teams wants (besides what's
> in the "normal" system libs.) Whether it works or not is a different
> question.
> It most likely will, though, if I set up the necessary LD_PRELOAD etc.
> (haven't been able to try because I needed to have a Teams version i
> *knew* worked.)  It's unlikely that there are "changes which the team
> doesn't expect"; I'm reasonably sure this is a straight
> rebuild/repackaging of newer upstream "libstdc++". It's also not an
> integral part of Chrome, but rather a package someone related to the
> Fedora team made to allow a certain "upstream" versions of chrome to
> work on a certain "downstream" OS release.
>> Also teams is looking for `rpm -q --whatprovides
>> 'libstdc++.so.6(GLIBCXX_3.4.20)(64bit)'` and you typed
>> `rpm -q --whatprovides 'libstdc++.so.6(GLIBCXX_3.4.22)(64bit)'`
> No, it looks for several different "libstdc++.so.6" versions, and the
> "chrome" package provides them all. I just listed one of them to
> illustrate the point.

I'm not sure that's true. You said your chrome package provides it all but
from what I see, it installs its libs into /opt/google/chrome/lib. But,
your system doesn't know about private libs installed in /opt and I think
the chrome package should NOT "provide" its private libs in its RPM

IMHO, if it's like that, then the chrome packages are crap :-)

What happens if you try this:

$ export LD_LIBRARY_PATH=/opt/google/chrome/lib
$ teams....

Or maybe even add

$ export LD_PRELOAD=/opt/google/chrome/lib/libstdc++.so.6