[CentOS] Microsoft Teams on CentOS 7. Does the latest version work?

Fri Jul 16 10:19:43 UTC 2021
Simon Matter <simon.matter at invoca.ch>

> On 16/07/21 8:41 pm, Simon Matter wrote:
>>> No, it looks for several different "libstdc++.so.6" versions, and the
>>> "chrome" package provides them all. I just listed one of them to
>>> illustrate the point.
>> I'm not sure that's true. You said your chrome package provides it all
>> but
>> from what I see, it installs its libs into /opt/google/chrome/lib. But,
>> your system doesn't know about private libs installed in /opt and I
>> think
>> the chrome package should NOT "provide" its private libs in its RPM
>> packages.
> I think you missed from a different post where the package was created
> by a different 3rd-party, not google.  So how else would you expect the
> 3rd-party package to satisfy the dependency?

I didn't say the chrome packages came from google. But, the TO has some
chrome RPM installed which "provides" the libstdc++ version required by
teams, but doesn't really provide this libstdc++ version to the whole
system. That's why the RPM is broken, it claims to provide a libstdc++
version which it doesn't really provide.

It may have worked before because older teams required a libstdc++ version
which is available on CentOS 7.

>> IMHO, if it's like that, then the chrome packages are crap :-)

The broken chrome packages are the reason why RPM allowed the new teams
version being installed. But because the chrome package doesn't really
provide to the systems what it claims, teams won't work an is in a broken

Did I miss something?


> The chrome packages are not built for CentOS or supported on such, it is
> coincidence that they happened to have worked in the past.  They will
> continue to work if the libstdc++ dependency is satisfied.
>> What happens if you try this:
>> $ export LD_LIBRARY_PATH=/opt/google/chrome/lib
>> $ teams....
> Better to just do:
> LD_LIBRARY_PATH=/opt/google/chrome/lib teams
> ...or if you have a desktop launcher that you use, edit the command and
> add this to the beginning:
> env LD_LIBRARY_PATH=/opt/google/chrome/lib
> Peter
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> https://lists.centos.org/mailman/listinfo/centos