[CentOS] Centos 8 host -> VMware host

Mon Mar 22 19:02:52 UTC 2021
Gregory P. Ennis <PoMec at PoMec.Net>


My final solution to the moving a Centos 7 machine to VMWare turned out to be the use of
vCenter Converter Standalone that has to be executed on a Windows machine.  I ran
this product on a kvm guest Windows 10 machine and it worked very well.  The transfer had
to be done while the Centos 7 machine was booted.  I have used this now to transfer a kvm
guest Centos 7 machine and a physical machine Centos 7 both to VMWare.

There was a problem when I booted both machines that occurred at the beginning of the boot
process before the kernel was accepted.  The screen was filed with error messages which
stated repetitively :

"error: can't find command ':'"

I had to enter a <Cr> several times to bypass the error messages and the the boot proceed

I found :

Apparently the VMWare converter has a bug in it that adds ": " to the beginning of a line
that starts with "#" in /boot/grub2/grub.cfg

All I needed to do was to edit grub.cfg and  remove the ": " that was present in many of
the lines that had previously been commented.  

A reboot was normal.

If any of you find a way to do this task with Linux I would surely like to hear from you,
but if you are looking for a way to make a migration from a physical machine or guest
machine to VMWare this worked well.  

Greg Ennis