[CentOS] Troubles expanding file system.

Wed Sep 1 16:42:09 UTC 2021
Jeff Boyce <jboyce at meridianenv.com>

Greetings -

     I have tried posting this four times now, from two different email 
addresses (on the 25th, 27th, 30th, and 31st) and it never appeared.  I 
don't see it in the archives, so it appears to be getting dropped in 
transition for some reason.  I am not getting messages from the email 
system saying it is undeliverable, or is bounced; I am sending as plain 
text, not HTML, I stripped off my signature.  If this makes it through, 
someone please give me a clue why the others might not have.  But that 
is not as important as the real issue that I am trying to get addressed 
below.  Thanks for any assistance.

     I have a Dell PowerEdge server with a CentOS KVM host (Earth) with 
one CentOS guest (Sequoia) that I am trying to expand the partition and 
filesystem on.  I have LVM logical volumes on the host system (Earth), 
which are used as devices/partitions on the guest system (Sequoia).  In 
this particular situation I have successfully extended the logical 
volume (lv_SeqEco) on Earth from 500GB to 700GB.

1.  Checking the disk information (lsblk) on Earth shows that the 
logical volume (lv_SeqEco) is now listed as 700GB.

2.  Checking disk information (lsblk) on Sequoia shows that the disk 
/dev/vde is still listed as 500GB, and partition /dev/vde1 where the 
mount point /ecosystem is located is also listed as 500GB.

3.  I had tried using the resize2fs command to expand the filesystem on 
/dev/vde1, but it returned with the result that there was nothing to 
do.  Which makes sense now after I checked the disk information, since 
/dev/vde on Sequoia has not increased from 500GB to 700GB.

4.  On previous occasions when I have done this task, I would just start 
GParted on Sequoia and use the GUI to expand the partition and 
filesystem.  A real quick and simple solution.

5.  The problem I have now is that the VGA adapter on my server has died 
and I have no graphical output to the attached monitor, nor to the iDrac 
console display.  So I am stuck doing this entirely by the command line 
while logged into the system remotely.

6.  I suspect that I need to rescan the devices on Sequoia so that it 
recognizes the increased space that has been allocated from the extended 
the logical volume.  But when I did that (command below) it came back 
with a no such file or directory.

echo 1 > /sys/class/block/vde1/device/rescan

7.  This server is being retired in the next few months, but I need this 
additional space prior to migrating to the new system. Can someone give 
me some guidance on what I am missing in this sequence?

Let me know if I haven't been clear enough in the explanation of my 
systems and objective.  Thanks.