[Ci-users] Jenkins Gerrit Trigger problem, please investigate

Attila Darazs adarazs at redhat.com
Thu Jun 8 14:03:02 UTC 2017


Dear CentOS CI admins,

We realized that some of our jobs are not triggering properly when we 
submit changes to review.openstack.org. None of our jobs that is using 
this gerrit server triggers any more.

We did not change anything in the jobs configs recently, the jobs are 
set up to use the "rdo-ci-openstack.org" gerrit server and trigger on 
any change.

What's weird is that if we go to 
https://ci.centos.org/gerrit_manual_trigger/ then we can manually 
trigger the jobs that were supposed to be running automatically.

Example test change: https://review.openstack.org/472267

Submitted: 2017-06-08 13:44 UTC

One of the gates jobs that were supposed to trigger, but nothing 
happened: 
https://ci.centos.org/view/rdo/view/tripleo-gate/job/tripleo-quickstart-gate-master-delorean-quick-basic/

Manually triggered at (with rdo-ci-openstack.org) 2017-06-08 13:58 UTC

Triggered Builds
   472267,1
     tripleo-quickstart-gate-ocata-delorean-quick-basic   #530
     tripleo-quickstart-gate-master-delorean-quick-basic  #2290
     tripleo-quickstart-gate-newton-delorean-quick-basic  #1453

As far as I can tell this was the last of our jobs that was still 
properly triggered by gerrit, 11 days ago: 
https://ci.centos.org/job/tripleo-quickstart-extras-gate-newton-delorean-full-minimal/825/

Please look into this, it seems to me that somehow the connection that 
listens to Gerrit events is down and it's important for us to have these 
gates running.

Thanks,
Attila



More information about the Ci-users mailing list