[Ci-users] CentOS 8 and CentOS 8-Stream now available in CI

Tue Nov 5 11:18:21 UTC 2019
František Šumšal <frantisek at sumsal.cz>


First of all - wonderful news! I went ahead and tried to switch our
RHEL8 systemd job to CentOS 8, but it looks like there an issue
with the internal repo mirrors:

+ dnf -v makecache
Loaded plugins: builddep, changelog, config-manager, copr, debug, debuginfo-install, download, generate_completion_cache, needs-restarting, playground, repoclosure, repodiff, repograph, repomanage, reposync
DNF version: 4.0.9
cachedir: /var/cache/dnf
Making cache files for all metadata files.
AppStream: has expired and will be refreshed.
BaseOS: has expired and will be refreshed.
extras: has expired and will be refreshed.
repo: downloading from remote: AppStream
error: Status code: 404 for http://mirror.ci.centos.org/altarch/8/AppStream/x86_64/repodata/repomd.xml (http://mirror.ci.centos.org/altarch/8/AppStream/x86_64/repodata/repomd.xml).
error: Status code: 404 for http://mirror2.ci.centos.org/altarch/8/AppStream/x86_64/repodata/repomd.xml (http://mirror2.ci.centos.org/altarch/8/AppStream/x86_64/repodata/repomd.xml).
error: Status code: 404 for http://mirror3.ci.centos.org/altarch/8/AppStream/x86_64/repodata/repomd.xml (http://mirror3.ci.centos.org/altarch/8/AppStream/x86_64/repodata/repomd.xml).
error: Status code: 404 for http://mirror4.ci.centos.org/altarch/8/AppStream/x86_64/repodata/repomd.xml (http://mirror4.ci.centos.org/altarch/8/AppStream/x86_64/repodata/repomd.xml).
error: Status code: 404 for http://mirror.centos.org/altarch/8/AppStream/x86_64/repodata/repomd.xml (http://mirror.centos.org/altarch/8/AppStream/x86_64/repodata/repomd.xml).
CentOS-8 - AppStream                             17 kB/s | 244  B     00:00    
Cannot download 'http://mirrorlist.centos.org/?release=8&arch=x86_64&repo=AppStream&infra=stock': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried.
Error: Failed to synchronize cache for repo 'AppStream'

This happened on all CentOS 8 machines (haven't tried 8-stream) I got from
Duffy yesterday/today.


On 10/30/19 9:52 PM, Vipul Siddharth wrote:
> Hello everyone,
> This is an email to inform you that now you can checkout CentOS 8 and
> CentOS 8-Stream nodes in CI. We have upgraded all the agents with the
> latest cico client which supports the parameter --release=8 and
> --release=8-stream.
> Here is a minimal example to get an 8/8-stream node
> `cico node get --release=8`
> `cico node get --release=8-stream`
> You should be able to use all other parameters like earlier.
> In case you see any problem with them, please let us know here or on
> #centos-ci at Freenode.
> Thank you

Frantisek Sumsal
GPG key ID: 0xFB738CE27B634E4B

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <http://lists.centos.org/pipermail/ci-users/attachments/20191105/8a33fa98/attachment-0004.sig>